summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-10-20 15:59:42 -0400
committerMatt Turner <mattst88@gentoo.org>2023-10-20 16:07:47 -0400
commitdab9b818f5fb4bb8d07aca1480f1e28410e61437 (patch)
tree71680b0cc5a0f23cb5a2787ef9fc3660a2f57055 /x11-libs/xcb-util-cursor
parentxorg-3.eclass: Fetch xcb-util-* distfiles from lib/ (diff)
downloadgentoo-dab9b818f5fb4bb8d07aca1480f1e28410e61437.tar.gz
gentoo-dab9b818f5fb4bb8d07aca1480f1e28410e61437.tar.bz2
gentoo-dab9b818f5fb4bb8d07aca1480f1e28410e61437.zip
x11-libs/xcb-util-cursor: Version bump to 0.1.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/xcb-util-cursor')
-rw-r--r--x11-libs/xcb-util-cursor/Manifest1
-rw-r--r--x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-cursor/Manifest b/x11-libs/xcb-util-cursor/Manifest
index 833664e4c20d..2d8fdb33bce9 100644
--- a/x11-libs/xcb-util-cursor/Manifest
+++ b/x11-libs/xcb-util-cursor/Manifest
@@ -1 +1,2 @@
DIST xcb-util-cursor-0.1.4.tar.xz 265508 BLAKE2B 8d7eac0116652833e1835e9c7454bc859901e146b06985b3926fd5f7568d92f2249ef6ea17c2202fa247e36bb998ba5b76fa519e92ca5cd51eb778169c88218c SHA512 d27dd59a4d7ded9994dca77774421dd9533e3ee823b880af35d3219bd7340c89fbc61d1d0fa10e2991de2cac9e6395e09497769d7b8728eedc691e76649107b1
+DIST xcb-util-cursor-0.1.5.tar.xz 266788 BLAKE2B a6c2d3d539191fdf896814711f7483ddd5e450dbd11293d8fbf9b04a05ebc3a0e2374b910bc43dd57a8d33936c611048a1ba20563f2df585b5ceed69332c1942 SHA512 e2d14c3f0ab117524ba90d1a992b61717ccee04bc9e66c587a6a0f10571f15e89fc5db3413882ca7ce14ebc07b6b7b0a4ddecd59ba910e6ca654ea9b1c705ed5
diff --git a/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.5.ebuild b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.5.ebuild
new file mode 100644
index 000000000000..0202e50bf9a2
--- /dev/null
+++ b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb-cursor"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-image-0.3.9-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-0.3.9[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.8-r3:=
+ x11-base/xorg-proto"
+BDEPEND=">=dev-util/gperf-3.0.1"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-cursorpath='~/.cursors:~/.icons:/usr/local/share/cursors/xorg-x11:/usr/local/share/cursors:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/share/cursors/xorg-x11:/usr/share/cursors:/usr/share/pixmaps/xorg-x11:/usr/share/icons:/usr/share/pixmaps'
+)