summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2019-12-16 18:06:27 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2019-12-16 18:17:53 +0100
commit6bb301b0b8ba5a10eec7ccc5042f0e7745e41770 (patch)
tree77a486d53519d6328c174d139a07bf713933c4d7 /x11-libs/fox
parentx11-libs/fox: bump versions (diff)
downloadgentoo-6bb301b0b8ba5a10eec7ccc5042f0e7745e41770.tar.gz
gentoo-6bb301b0b8ba5a10eec7ccc5042f0e7745e41770.tar.bz2
gentoo-6bb301b0b8ba5a10eec7ccc5042f0e7745e41770.zip
x11-libs/fox: prepare for deletion of old cruft
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'x11-libs/fox')
-rw-r--r--x11-libs/fox/fox-1.7.67.ebuild67
-rw-r--r--x11-libs/fox/metadata.xml5
2 files changed, 57 insertions, 15 deletions
diff --git a/x11-libs/fox/fox-1.7.67.ebuild b/x11-libs/fox/fox-1.7.67.ebuild
index 9a65bf971467..0be6c0ddb46b 100644
--- a/x11-libs/fox/fox-1.7.67.ebuild
+++ b/x11-libs/fox/fox-1.7.67.ebuild
@@ -3,18 +3,16 @@
EAPI=5
-inherit fox
+inherit autotools versionator
LICENSE="LGPL-2.1"
SLOT="1.7"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib debug doc profile"
-# newish autoconf needed for working mmap check
RDEPEND="x11-libs/libXrandr
x11-libs/libXcursor
x11-libs/fox-wrapper
- >=sys-devel/autoconf-2.67
bzip2? ( app-arch/bzip2 )
jpeg? ( virtual/jpeg:= )
opengl? ( virtual/glu virtual/opengl )
@@ -22,38 +20,79 @@ RDEPEND="x11-libs/libXrandr
tiff? ( media-libs/tiff:0= )
truetype? ( media-libs/freetype:2
x11-libs/libXft )
- zlib? ( sys-libs/zlib )"
+ zlib? ( sys-libs/zlib )
+ doc? ( app-doc/doxygen )
+"
DEPEND="${RDEPEND}
x11-base/xorg-proto
x11-libs/libXt"
+DESCRIPTION="C++ Toolkit for developing Graphical User Interfaces easily and effectively"
+HOMEPAGE="http://www.fox-toolkit.org/"
+SRC_URI="ftp://ftp.fox-toolkit.org/pub/${P}.tar.gz"
+
src_prepare() {
- fox_src_prepare
sed -i '/#define REXDEBUG 1/d' lib/FXRex.cpp || die "Unable to remove spurious debug line."
+ local d
+ for d in windows adie calculator pathfinder shutterbug; do
+ sed -i -e "s:${d}::" Makefile.am || die "Unable to remove $d."
+ done
+
+ # Respect system CXXFLAGS
+ sed -i -e 's:CXXFLAGS=""::' configure.ac || die "Unable to force cxxflags."
+
+ # don't strip binaries
+ sed -i -e '/LDFLAGS="-s ${LDFLAGS}"/d' configure.ac || die "Unable to prevent stripping."
+
+ eautoreconf
}
src_configure() {
- FOXCONF="$(use_enable bzip2 bz2lib) \
+ econf \
+ $(use debug && echo --enable-debug || echo --enable-release) \
+ $(use_enable bzip2 bz2lib) \
$(use_enable jpeg) \
$(use_with opengl) \
$(use_enable png) \
$(use_enable tiff) \
$(use_with truetype xft) \
- $(use_enable zlib)" fox_src_configure
+ $(use_enable zlib) \
+ $(use_with profile profiling)
+}
+
+src_compile() {
+ emake || die "compile error"
+ use doc && emake -C "${S}"/doc docs
}
src_install() {
- fox_src_install
+ emake install \
+ DESTDIR="${D}" \
+ htmldir=/usr/share/doc/${PF}/html \
+ artdir=/usr/share/doc/${PF}/html/art \
+ screenshotsdir=/usr/share/doc/${PF}/html/screenshots
+
CP="${ED}/usr/bin/ControlPanel"
if [[ -f ${CP} ]] ; then
mv "${CP}" "${ED}/usr/bin/fox-ControlPanel-${SLOT}" || \
die "Failed to install ControlPanel"
fi
-}
-pkg_postinst() {
- fox_pkg_postinst
+ for doc in ADDITIONS AUTHORS LICENSE_ADDENDUM README TRACING ; do
+ [ -f $doc ] && dodoc $doc
+ done
+
+ # remove documentation if USE=-doc
+ use doc || rm -fr "${D}/usr/share/doc/${PF}/html"
- einfo "ControlPanel has been installed to 'fox-ControlPanel-${SLOT}' to avoid conflicts"
- einfo "with other packages."
+ # install class reference docs if USE=doc
+ if use doc && [[ -z ${FOX_COMPONENT} ]] ; then
+ dohtml -r "${S}/doc/ref"
+ fi
+
+ # slot fox-config
+ if [[ -f ${D}/usr/bin/fox-config ]] ; then
+ mv "${D}/usr/bin/fox-config" "${D}/usr/bin/fox-$(get_version_component_range 1-2 ${PV})-config" \
+ || die "failed to install fox-config"
+ fi
}
diff --git a/x11-libs/fox/metadata.xml b/x11-libs/fox/metadata.xml
index 7a38bb900964..915f00227065 100644
--- a/x11-libs/fox/metadata.xml
+++ b/x11-libs/fox/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
</pkgmetadata>