summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-03 19:54:43 -0500
committerMatt Turner <mattst88@gentoo.org>2024-03-03 19:57:50 -0500
commit7aed8781ed76b46b748d89f262522f71f9dff00b (patch)
tree85faa04cfb0ead2f95ac68555556189df246cf3e /x11-apps
parentx11-apps/xrefresh: Version bump to 1.1.0 (diff)
downloadgentoo-7aed8781ed76b46b748d89f262522f71f9dff00b.tar.gz
gentoo-7aed8781ed76b46b748d89f262522f71f9dff00b.tar.bz2
gentoo-7aed8781ed76b46b748d89f262522f71f9dff00b.zip
x11-apps/xsm: Version bump to 1.0.6
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xsm/Manifest1
-rw-r--r--x11-apps/xsm/xsm-1.0.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/x11-apps/xsm/Manifest b/x11-apps/xsm/Manifest
index 908f4156fd4c..0c9171c73b96 100644
--- a/x11-apps/xsm/Manifest
+++ b/x11-apps/xsm/Manifest
@@ -1 +1,2 @@
DIST xsm-1.0.5.tar.xz 159496 BLAKE2B 18531fd06970a244478cd674cac1d669d4fcecb4f680a656c5182927c76a111aa82b96fd96e5b887d6f8b44e7ab88292607812b7d6bbcac86d9f4448bbb4fed5 SHA512 df3777b3aab813ec8aa906f5a03f93b8ca645978970290cf7baf732e175c36c00ae19baeb45ea7404d35838c21e6f8fca28f0da3e2f398d17adac5f2acb7b351
+DIST xsm-1.0.6.tar.xz 160724 BLAKE2B 74d03422ae182d8f3b75234065ec1ab5c30d1a6230e17691c1df7ec8658c21ee18486eaa2c8a14710d604fcdbb39869d75516a13dcc1855e5a4c46ad2d5d4f7d SHA512 ee4e9b4ab6be6773e53685540f807b03d553bfecc26c4e85fe12daca486fdeb66c594c6eab54043a8c149112c7a3ed18e463d68d7aee62e93a06c091ce39c268
diff --git a/x11-apps/xsm/xsm-1.0.6.ebuild b/x11-apps/xsm/xsm-1.0.6.ebuild
new file mode 100644
index 000000000000..1fe975b89ec7
--- /dev/null
+++ b/x11-apps/xsm/xsm-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X Session Manager"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_setup() {
+ # (#158056) /usr/$(get_libdir)/X11/xsm could be a symlink
+ local XSMPATH="${EROOT}/usr/$(get_libdir)/X11/xsm"
+ if [[ -L ${XSMPATH} ]]; then
+ einfo "Removing symlink ${XSMPATH}"
+ rm -f ${XSMPATH} || die "failed to remove symlink ${XSMPATH}"
+ fi
+ xorg-3_pkg_setup
+}