summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2023-04-03 09:30:16 +0200
committerSam James <sam@gentoo.org>2023-04-16 07:47:32 +0100
commit4999c5e769737f642df960bdeff4b00a41740b82 (patch)
treeedfa6979d2dbb2877e75cf2cee6af64189b1e67f /www-servers/sniproxy
parentgames-emulation/cega-jg: add 0.6.0 (diff)
downloadgentoo-4999c5e769737f642df960bdeff4b00a41740b82.tar.gz
gentoo-4999c5e769737f642df960bdeff4b00a41740b82.tar.bz2
gentoo-4999c5e769737f642df960bdeff4b00a41740b82.zip
www-servers/sniproxy: Bump to 0.6.1
Bug: https://bugs.gentoo.org/903716 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-servers/sniproxy')
-rw-r--r--www-servers/sniproxy/Manifest1
-rw-r--r--www-servers/sniproxy/sniproxy-0.6.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/www-servers/sniproxy/Manifest b/www-servers/sniproxy/Manifest
index 7c2380a9ee3f..de16ec378fb9 100644
--- a/www-servers/sniproxy/Manifest
+++ b/www-servers/sniproxy/Manifest
@@ -1 +1,2 @@
DIST sniproxy-0.6.0.tar.gz 78515 BLAKE2B 1ac8decc793e7b3d73d833bc392b3ef035bd2ba7d515c54ff46de16ee8897c0c5392929d5c7a22a131c1f017897cc6f8e9c50aff8164e4afbdc23155b804b613 SHA512 8a99573673bdd57e528c5781cb166d39c80daed699382b24c3fa18a6011d074a1d9e470fee404d24b4450cf067c9995125910b2941b5216d88d189a1d79ebf73
+DIST sniproxy-0.6.1.tar.gz 78939 BLAKE2B dd11d47779dbf876724a8e0951c137343c25e420ca0b34055adbd31abda9ad56e38d1addd3ab0a7d85079fec3a456faba87df9cdf261570d8c1d7cfdf534f852 SHA512 4a20830ee6dfeb33a363c480c4698c263a8deccfcac2071198248147ef40d951a1b551c373b0e1e29f6b6bfcdac350390f8f4c3653ed9d1f1940ed50c96af785
diff --git a/www-servers/sniproxy/sniproxy-0.6.1.ebuild b/www-servers/sniproxy/sniproxy-0.6.1.ebuild
new file mode 100644
index 000000000000..f95fb68f3e20
--- /dev/null
+++ b/www-servers/sniproxy/sniproxy-0.6.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/dlundquist/sniproxy.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/dlundquist/sniproxy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Proxies incoming HTTP and TLS connections based on the hostname"
+HOMEPAGE="https://github.com/dlundquist/sniproxy"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="+dns +largefile rfc3339 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-group/sniproxy
+ acct-user/sniproxy
+ dev-libs/libev
+ >=dev-libs/libpcre-3
+ dns? ( net-libs/udns )"
+DEPEND="${RDEPEND}
+ test? ( net-misc/curl )"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ sed -i "/user/s/daemon/sniproxy/" debian/sniproxy.conf || die "Unable to replace configuration"
+ sed -i "/create/s/daemon/sniproxy/" debian/logrotate.conf || die "Unable to replace logrotate configuration"
+}
+
+src_configure() {
+ local my_conf=(
+ $(use_enable dns)
+ $(use_enable largefile)
+ $(use_enable rfc3339 rfc3339-timestamps)
+ )
+
+ econf "${my_conf[@]}"
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/sniproxy.init" sniproxy
+
+ insinto /etc/sniproxy
+ doins debian/sniproxy.conf
+
+ keepdir /var/log/sniproxy
+
+ insinto /etc/logrotate.d
+ newins debian/logrotate.conf sniproxy
+
+ dodoc ARCHITECTURE.md AUTHORS README.md
+ doman man/sniproxy.8
+ doman man/sniproxy.conf.5
+}