summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-03-21 18:23:16 -0400
committerAaron Bauman <bman@gentoo.org>2019-03-21 18:23:56 -0400
commit7de462fe77d5b1cd89a31efebcd71d4a0f697682 (patch)
treea1baf86e70a74b626378e2c032070e6081f836c3 /www-servers/gunicorn/gunicorn-19.4.5.ebuild
parentnet-fs/mc: Version bump (diff)
downloadgentoo-7de462fe77d5b1cd89a31efebcd71d4a0f697682.tar.gz
gentoo-7de462fe77d5b1cd89a31efebcd71d4a0f697682.tar.bz2
gentoo-7de462fe77d5b1cd89a31efebcd71d4a0f697682.zip
www-servers/gunicorn: drop vulnerable wrt bug #653590
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'www-servers/gunicorn/gunicorn-19.4.5.ebuild')
-rw-r--r--www-servers/gunicorn/gunicorn-19.4.5.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/www-servers/gunicorn/gunicorn-19.4.5.ebuild b/www-servers/gunicorn/gunicorn-19.4.5.ebuild
deleted file mode 100644
index e926a618c442..000000000000
--- a/www-servers/gunicorn/gunicorn-19.4.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A WSGI HTTP Server for UNIX"
-HOMEPAGE="http://gunicorn.org https://pypi.org/project/gunicorn/ https://github.com/benoitc/gunicorn"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-DOCS="README.rst"
-
-python_prepare_all() {
- sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}