summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-misc/litmus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-misc/litmus')
-rw-r--r--www-misc/litmus/Manifest1
-rw-r--r--www-misc/litmus/files/0.13-autotools-neon-version.patch11
-rw-r--r--www-misc/litmus/litmus-0.13.ebuild62
-rw-r--r--www-misc/litmus/metadata.xml15
4 files changed, 89 insertions, 0 deletions
diff --git a/www-misc/litmus/Manifest b/www-misc/litmus/Manifest
new file mode 100644
index 000000000000..55d8f096bfcc
--- /dev/null
+++ b/www-misc/litmus/Manifest
@@ -0,0 +1 @@
+DIST litmus-0.13.tar.gz 467532 SHA256 09d615958121706444db67e09c40df5f753ccf1fa14846fdeb439298aa9ac3ff SHA512 a1c04a17cbe4a17b5e0ed768017296256c9f234ae3f238f838f55064855b254246ba1d2e41b07145e1a9587698145b36b67e31488cfce817a9b5b119ee505b1e WHIRLPOOL a9809b9e3a3faf0f51dc234a117812442bac84dddfe339f1746094237096164bbfcab8eb4739d7c4a325480124828217194374401a1396e1c7f1f1807883e9eb
diff --git a/www-misc/litmus/files/0.13-autotools-neon-version.patch b/www-misc/litmus/files/0.13-autotools-neon-version.patch
new file mode 100644
index 000000000000..c2e0211b6508
--- /dev/null
+++ b/www-misc/litmus/files/0.13-autotools-neon-version.patch
@@ -0,0 +1,11 @@
+--- configure.ac.ori 2014-01-31 01:00:58.796123088 +0100
++++ configure.ac 2014-01-31 01:00:43.767787763 +0100
+@@ -20,7 +20,7 @@
+ dnl List of tests
+ AC_SUBST([TESTS], ["basic copymove props locks http"])
+
+-NE_REQUIRE_VERSIONS([0], [25 26 27 28 29])
++NE_REQUIRE_VERSIONS([0], [25 26 27 28 29 30])
+ NEON_WITHOUT_ZLIB
+ NEON_WITHOUT_ACL
+ NEON_TEST
diff --git a/www-misc/litmus/litmus-0.13.ebuild b/www-misc/litmus/litmus-0.13.ebuild
new file mode 100644
index 000000000000..90963bd5e11a
--- /dev/null
+++ b/www-misc/litmus/litmus-0.13.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+# TODO: FAIL (connection refused by '...' port 80: Connection refused)
+# We can't run tests that connect with the internet.
+RESTRICT="test"
+
+DESCRIPTION="WebDAV server protocol compliance test suite"
+HOMEPAGE="http://www.webdav.org/neon/litmus"
+SRC_URI="http://www.webdav.org/neon/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug expat gnutls kerberos libproxy +libxml2 pkcs11 +ssl threads"
+REQUIRED_USE="?? ( gnutls ssl )
+ ^^ ( expat libxml2 )
+ threads? ( ^^ ( gnutls ssl ) )"
+
+NEON_DEP="net-libs/neon:0="
+DEPEND="${NEON_DEP}[expat?,gnutls?,kerberos?,libproxy?,pkcs11?,ssl?,zlib]
+
+ expat? ( dev-libs/expat:0 )
+ gnutls? ( net-libs/gnutls:0 )
+ kerberos? ( app-crypt/mit-krb5:0 )
+ libproxy? ( net-libs/libproxy:0 )
+ libxml2? ( dev-libs/libxml2:2 )
+ pkcs11? ( dev-libs/pakchois:0 )
+ ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog FAQ NEWS README THANKS TODO )
+
+src_prepare() {
+ # Accept Neon 0.30.
+ epatch "${FILESDIR}/${PV}-autotools-neon-version.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ # No EGD available in the Portage tree.
+ econf \
+ --enable-warnings \
+ --without-egd \
+ --with-neon \
+ --without-included-neon \
+ $(use_enable debug) \
+ $(use_enable threads threadsafe-ssl posix) \
+ $(use_with gnutls ssl gnutls) \
+ $(use_with ssl ssl openssl) \
+ $(use_with expat) \
+ $(use_with libxml2) \
+ $(use_with kerberos gssapi) \
+ $(use_with pkcs11 pakchois) \
+ $(use_with libproxy)
+}
diff --git a/www-misc/litmus/metadata.xml b/www-misc/litmus/metadata.xml
new file mode 100644
index 000000000000..f0b5e4cd5d70
--- /dev/null
+++ b/www-misc/litmus/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>beber@meleeweb.net</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <longdescription>WebDAV server protocol compliance test suite</longdescription>
+ <use>
+ <flag name="libproxy">Support for automatic proxy configuratino management through <pkg>net-libs/libproxy</pkg>.</flag>
+ <flag name="libxml2">Use dev-libs/libxml2 to parse XML</flag>
+ <flag name="pkcs11">Support for PKCS #11 through PaKChoiS (<pkg>dev-libs/pakchois</pkg>).</flag>
+ </use>
+</pkgmetadata>