summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-02-24 19:20:59 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-02-24 19:21:13 +0100
commit37ed8fe93823d2d176d52ab47954c849455c87f6 (patch)
tree8fdd7feddbe2b60d397af7cfd67c4baf5f689f34 /www-apps
parentapp-portage/gs-elpa: add gentoo upstream metadata (diff)
downloadgentoo-37ed8fe93823d2d176d52ab47954c849455c87f6.tar.gz
gentoo-37ed8fe93823d2d176d52ab47954c849455c87f6.tar.bz2
gentoo-37ed8fe93823d2d176d52ab47954c849455c87f6.zip
www-apps/piwigo: add 13.6.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/piwigo/Manifest1
-rw-r--r--www-apps/piwigo/piwigo-13.6.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/piwigo/Manifest b/www-apps/piwigo/Manifest
index b8d8cfeb78f2..552341393ee3 100644
--- a/www-apps/piwigo/Manifest
+++ b/www-apps/piwigo/Manifest
@@ -1 +1,2 @@
DIST piwigo-13.5.0.zip 18298794 BLAKE2B 6fc432a3c2b4e70c3b3864047593aa91e0e4fe802db4f6d3b825c5467e7a062ae1e5ca85136c2c6660c50a05b9d2b76a80e802f5fd5c27f1733e5e32925f3fff SHA512 1020cc45f69e4af56761df84c1094ef3a81e1117fffede2ec3a15f52891ce2ef6e580c19a2228511e4a6c730e9d5aac3e0780166042a4907af85ee092e38957a
+DIST piwigo-13.6.0.zip 18292976 BLAKE2B 492230974533587742a0b1c9b344cef846f38fd3b6d756a1a0208afdef36ea7630b24e81f8de21280223030c3811112628f5f385ad083a20b802703a460f25ff SHA512 2c322af7dd74768b3192156ab5f59929de1f5a75061e00a628910253bab4f567f9d1d596d7fc648ccd12a9cd28b0ee8ac3d1fb71fc53002d142f62fabaab0724
diff --git a/www-apps/piwigo/piwigo-13.6.0.ebuild b/www-apps/piwigo/piwigo-13.6.0.ebuild
new file mode 100644
index 000000000000..825f7096685f
--- /dev/null
+++ b/www-apps/piwigo/piwigo-13.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json(+),mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+BDEPEND="app-arch/unzip"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}