summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/agendav
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/agendav')
-rw-r--r--www-apps/agendav/Manifest1
-rw-r--r--www-apps/agendav/agendav-1.2.6.2.ebuild79
-rw-r--r--www-apps/agendav/files/postinstall-en.txt13
-rw-r--r--www-apps/agendav/metadata.xml11
4 files changed, 104 insertions, 0 deletions
diff --git a/www-apps/agendav/Manifest b/www-apps/agendav/Manifest
new file mode 100644
index 000000000000..9ae3d800634f
--- /dev/null
+++ b/www-apps/agendav/Manifest
@@ -0,0 +1 @@
+DIST agendav-1.2.6.2.tar.gz 2586820 SHA256 af5a8a828a1204d3dc4f0457424e77d74505b98c23e1ce9a886af789541ba44c SHA512 bfae7c00ab7f8baf239310e2c04229ee76a56befc57d9ab449654bb0c28dd30aab628a2292670dc8c1ce479593bd1b6a57ba1e4f3bcffb4de27214c855ccabab WHIRLPOOL 952f1ebc2702ed3e13334951b89b7898059c0dd3b917b6c9eafde2bc4454fb6dcebcea575d20acf15cc3f1af53db88735e99aa68e20ecd1ca63390be9fa1b768
diff --git a/www-apps/agendav/agendav-1.2.6.2.ebuild b/www-apps/agendav/agendav-1.2.6.2.ebuild
new file mode 100644
index 000000000000..15ab2d69ff1e
--- /dev/null
+++ b/www-apps/agendav/agendav-1.2.6.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit webapp
+
+DESCRIPTION="multilanguage CalDAV web client"
+HOMEPAGE="http://agendav.org/"
+SRC_URI="https://github.com/adobo/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD LGPL-3+ LGPL-2.1+ GPL-3+"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-lang/php-5.3[curl,unicode]
+ virtual/httpd-php
+ || ( >=virtual/mysql-5.1 >=dev-db/postgresql-8.1 )"
+
+S=${WORKDIR}/adobo-${PN}-84f869e
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc \
+ doc/source/admin/configuration.rst \
+ doc/source/admin/installation.rst \
+ doc/source/admin/troubleshooting.rst \
+ doc/source/admin/upgrading.rst \
+ || die
+
+ # fix locations
+ sed -i \
+ -e "s:\(system_path = \)'[^']\+':\1'${MY_HOSTROOTDIR}/${PN}/system':" \
+ -e "s:\(application_folder = \)'[^']\+':\1'${MY_HOSTROOTDIR}/${PN}/application':" \
+ web/public/index.php || die
+ sed -i \
+ -e "/require_once/s:'../:'${MY_HOSTROOTDIR}/${PN}/:" \
+ web/config/autoload.php || die
+ sed -i \
+ -e "1a\set_include_path(get_include_path() . PATH_SEPARATOR . APPPATH.'config');" \
+ web/config/constants.php || die
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r web/public/* || die
+
+ einfo "Creating configuration container"
+ dodir "/etc/agendav"
+ local f
+ for f in caldav database config ; do
+ cp web/config/${f}.php.template "${ED}"/etc/agendav/${f}.php || die
+ ln -s "${EPREFIX}"/etc/agendav/${f}.php web/config/${f}.php || die
+ done
+
+ einfo "Installing main files"
+ insinto "${MY_HOSTROOTDIR}/${PN}"
+ doins -r web/{application,config,css_src,lang,system,templates_src,public} \
+ || die
+ insinto "${MY_HOSTROOTDIR}/${PN}/application/libraries"
+ doins libs/icalcreator/*.php \
+ libs/caldav-client/*.php \
+ libs/awl/*.php \
+ || die
+ dodir /usr/bin
+ cat > "${ED}"/usr/bin/agendavcli <<-EOF
+ #!/usr/bin/env bash
+
+ exec php "${MY_HOSTROOTDIR}/${PN}/public/index.php" cli "\${@}"
+ EOF
+ chmod 755 "${ED}"/usr/bin/agendavcli
+
+ einfo "Installing sql files"
+ insinto "${MY_SQLSCRIPTSDIR}"
+ doins -r sql/* || die
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+}
diff --git a/www-apps/agendav/files/postinstall-en.txt b/www-apps/agendav/files/postinstall-en.txt
new file mode 100644
index 000000000000..5301576c6498
--- /dev/null
+++ b/www-apps/agendav/files/postinstall-en.txt
@@ -0,0 +1,13 @@
+Next to a CalDAV server, you need access to a mysql or postgresql
+database to use agendav.
+
+Read /usr/share/doc/www-apps/agendav-${PVR}/installation.rst.bz2 for
+installation instructions of the database. This includes loading the
+SQL statements from /usr/share/webapps/agendav/${PVR}/sqlscripts/.
+
+Next you have to edit all config files in /etc/agendav/.
+
+Before you can use agendav, you need to upgrade the database (even
+though this is a new install) using:
+
+ $ agendavcli dbupdate
diff --git a/www-apps/agendav/metadata.xml b/www-apps/agendav/metadata.xml
new file mode 100644
index 000000000000..c4dd21f48526
--- /dev/null
+++ b/www-apps/agendav/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>grobian@gentoo.org</email>
+ <name>Fabian Groffen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">adobo/agendav</remote-id>
+ </upstream>
+</pkgmetadata>