summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-30 01:30:57 +0000
committerSam James <sam@gentoo.org>2025-01-30 01:30:57 +0000
commit2d18b8a2604bec66cb5175043f6da41e5e97d5aa (patch)
tree476f90c343d4fe856d21cf45820e2a40246b70bf /www-apache
parenttoolchain.eclass: add TODO for --enable-version-specific-runtime-libs (diff)
downloadgentoo-2d18b8a2604bec66cb5175043f6da41e5e97d5aa.tar.gz
gentoo-2d18b8a2604bec66cb5175043f6da41e5e97d5aa.tar.bz2
gentoo-2d18b8a2604bec66cb5175043f6da41e5e97d5aa.zip
www-apache/mod_auth_openidc: add 2.4.16.7
Closes: https://bugs.gentoo.org/932521 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_auth_openidc/Manifest1
-rw-r--r--www-apache/mod_auth_openidc/mod_auth_openidc-2.4.16.7.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/www-apache/mod_auth_openidc/Manifest b/www-apache/mod_auth_openidc/Manifest
index 996d5dfef207..4a0bb4673b52 100644
--- a/www-apache/mod_auth_openidc/Manifest
+++ b/www-apache/mod_auth_openidc/Manifest
@@ -1 +1,2 @@
DIST mod_auth_openidc-2.4.14.4.tar.gz 632757 BLAKE2B e01df9c431df848c1773f8152d87b5efc183b016516718bbf5eff3de66d12c87396b649a06548b5f0e42a52d08baef9ced8cd4b79acfc1657b7427dab0c9c14d SHA512 b7d61f15d48292f2a567653632f7d9df8b6cb54303d4de0c333c8122a32df8749e508a0abd5259ac7ca15da5b244eec1e1d21f62140720ddb1705ec289551984
+DIST mod_auth_openidc-2.4.16.7.tar.gz 688803 BLAKE2B ddebeea109f2a33fb2bf71c4f1311f6b2bae6cd2cd6b6d4d3124ec0a99cca82ad7ee209f62ded3070390fff7c65ee062f758f410eea7f7cba3dcfef9c6b31ee6 SHA512 0f0d656294eab0c7bc5c8e637765ca58f0e9465cfb7971041d0efd41f67ccc1dcd4417cc4d0d3629eb05fe42e859804f4d39e3beae7285e582f4e373826da383
diff --git a/www-apache/mod_auth_openidc/mod_auth_openidc-2.4.16.7.ebuild b/www-apache/mod_auth_openidc/mod_auth_openidc-2.4.16.7.ebuild
new file mode 100644
index 000000000000..a7be85f3665b
--- /dev/null
+++ b/www-apache/mod_auth_openidc/mod_auth_openidc-2.4.16.7.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit depend.apache apache-module autotools
+
+DESCRIPTION="OpenID Connect Relying Party implementation for Apache HTTP Server 2.x"
+HOMEPAGE="https://github.com/OpenIDC/mod_auth_openidc"
+SRC_URI="https://github.com/OpenIDC/mod_auth_openidc/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="brotli redis"
+
+RDEPEND="
+ app-misc/jq
+ dev-libs/apr
+ dev-libs/cjose
+ dev-libs/jansson:=
+ dev-libs/openssl:=
+ dev-libs/libpcre
+ net-misc/curl
+ sys-libs/zlib:=
+ brotli? ( app-arch/brotli:= )
+ redis? ( dev-libs/hiredis:= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="virtual/pkgconfig"
+
+APACHE2_MOD_CONF="10_mod_auth_openidc"
+APACHE2_MOD_DEFINE="AUTH_OPENIDC"
+DOCFILES="README.md ChangeLog AUTHORS INSTALL auth_openidc.conf"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_ARGS=(
+ $(use_with brotli)
+ $(use_with redis hiredis)
+ )
+
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${ECONF_ARGS[@]}"
+}
+
+src_compile() {
+ # Do not use apache-module_src_compile ; it does not compile properly
+ default
+}
+
+src_install() {
+ # Do not use apache-module_src_install ; it does not link properly
+ default
+
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}/${APACHE2_MOD_CONF}.conf"
+ dodoc ${DOCFILES}
+}
+
+pkg_postinst() {
+ apache-module_pkg_postinst
+}