summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-02-08 19:25:59 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-08 19:25:59 +0200
commite60ca0a7e4dff0b3a9890c60e76ec7d2baed7938 (patch)
tree1478a186cd5504c7ec218d5b70fadcade38b5aa9 /sys-process
parentnet-dns/libidn: Stabilize 1.42 arm64, #924097 (diff)
downloadgentoo-e60ca0a7e4dff0b3a9890c60e76ec7d2baed7938.tar.gz
gentoo-e60ca0a7e4dff0b3a9890c60e76ec7d2baed7938.tar.bz2
gentoo-e60ca0a7e4dff0b3a9890c60e76ec7d2baed7938.zip
sys-process/iotop-c: add 1.26
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/iotop-c/Manifest1
-rw-r--r--sys-process/iotop-c/iotop-c-1.26.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
index 818c9a715e0a..b79e1b52f475 100644
--- a/sys-process/iotop-c/Manifest
+++ b/sys-process/iotop-c/Manifest
@@ -1 +1,2 @@
DIST iotop-c-1.25.tar.gz 139627 BLAKE2B a159ae3a4e5be87776d7111e38685e2f83fd907b82a09ec9b4a7d5c778d3a2c5a6e544452c126ff76b0fca2a4038cec1415a654156186dfb2534649a295eb65c SHA512 b696d0478e08373a923475493d67912959d78369f086179590482fb8e6ec349d0c8f5e6118e0aa353d2827b8d83f14bf334cf50cf55f6859bd8d9317543031e0
+DIST iotop-c-1.26.tar.gz 139536 BLAKE2B 90bb3db7dd3b05604fa5368a881434eac06509921447fd53bda7e7291e2c823f82f9015f0c16c516dcfa7c8ee6198466b8634eaf1b111b4f911645b97fc2634f SHA512 47246bc025c396bcd7569bd19d52079701e3b86ab239ac3db1d1386f358f6e95a63d7bad8c1d0552fb61315a9db282967c65e110703863ae71fa6260b775942b
diff --git a/sys-process/iotop-c/iotop-c-1.26.ebuild b/sys-process/iotop-c/iotop-c-1.26.ebuild
new file mode 100644
index 000000000000..8206a88232a6
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.26.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/iotop-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ !sys-process/iotop
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_prepare() {
+ sed -e 's/-D_FORTIFY_SOURCE=2//' -i Makefile || die
+ default
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}