summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-03-22 19:11:51 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-03-22 19:13:45 +0100
commite064a543ab94d8c2378fe1368292e78f6f6af0f2 (patch)
tree6a813458327605d3a923dac675fc9cdabdae08e6 /sys-process
parentnet-misc/tigervnc: Fix the init script (diff)
downloadgentoo-e064a543ab94d8c2378fe1368292e78f6f6af0f2.tar.gz
gentoo-e064a543ab94d8c2378fe1368292e78f6f6af0f2.tar.bz2
gentoo-e064a543ab94d8c2378fe1368292e78f6f6af0f2.zip
sys-process/cronie: Bump to version 1.6.0
Do some more anacron adjustments. Hopefully all is set now for anacron. Use /run instead of /var/run for pidfile. Bug: https://bugs.gentoo.org/825026 Closes: https://bugs.gentoo.org/685306 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/cronie/Manifest1
-rw-r--r--sys-process/cronie/cronie-1.6.0.ebuild116
-rw-r--r--sys-process/cronie/files/cronie-1.3-initd2
3 files changed, 118 insertions, 1 deletions
diff --git a/sys-process/cronie/Manifest b/sys-process/cronie/Manifest
index d7b2a169a5dc..8238b355cca7 100644
--- a/sys-process/cronie/Manifest
+++ b/sys-process/cronie/Manifest
@@ -1 +1,2 @@
DIST cronie-1.5.7.tar.gz 148739 BLAKE2B 3e9f8b78a29d2304e2ece7ce2b794b80e6023428d5b07f21936f3690eae2741b9e6814f966d8e3cb3d4f9daf32b3fe730ce6adebb76f8779c3f5039d2a19b6a4 SHA512 cddf1ffd518bf8daed8ae2634ace41da669f6d1039b1936b602200e2f2902944d8e84c80f73f6ab67b2fa755c4192f9181cf44d87bc893201b756367ab55148e
+DIST cronie-1.6.0.tar.gz 149859 BLAKE2B 0b63b07d8138c74c57ff0cbe1ae3cd3abb21178116322327d06cbc5e12a0c54e5f2512fb9f810787721f7ad1bba897f206b96fd83645bbfeeace734eedbcaf3d SHA512 9d078e2f8ffc0d2feaa16d419fcccf354f8de8021869b14d315b6f0a0acbd888da98fb47888b71672354ec221bbbaf5b77a543b909ae44b0fc6d2b39394ddf5b
diff --git a/sys-process/cronie/cronie-1.6.0.ebuild b/sys-process/cronie/cronie-1.6.0.ebuild
new file mode 100644
index 000000000000..803851ce4c04
--- /dev/null
+++ b/sys-process/cronie/cronie-1.6.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools cron flag-o-matic pam systemd
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
+HOMEPAGE="https://github.com/cronie-crond/cronie"
+SRC_URI="https://github.com/cronie-crond/cronie/archive/${P}.tar.gz"
+
+LICENSE="ISC BSD BSD-2 GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+anacron +inotify pam selinux"
+
+DEPEND="
+ acct-group/crontab
+ pam? ( sys-libs/pam )
+ anacron? (
+ !sys-process/anacron
+ !sys-process/systemd-cron
+ elibc_musl? ( sys-libs/obstack-standalone )
+ )
+"
+RDEPEND="${DEPEND}
+ sys-apps/debianutils
+"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.3-systemd.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with inotify)
+ $(use_with pam)
+ $(use_with selinux)
+ $(use_enable anacron)
+ --enable-syscrontab
+ --with-daemon_username=cron
+ --with-daemon_groupname=cron
+ )
+
+ if use anacron ; then
+ if use elibc_musl ; then
+ append-cflags "-lobstack"
+ fi
+ fi
+ SPOOL_DIR="/var/spool/cron/crontabs" \
+ ANACRON_SPOOL_DIR="/var/spool/anacron" \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docrondir -m 1730 -o root -g crontab
+ fowners root:crontab /usr/bin/crontab
+ fperms 2751 /usr/bin/crontab
+
+ newconfd "${S}"/crond.sysconfig ${PN}
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ insinto /etc/cron.d
+ doins contrib/dailyjobs
+
+ newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
+
+ if use pam ; then
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+ fi
+
+ systemd_newunit contrib/cronie.systemd cronie.service
+
+ if use anacron ; then
+ local anacrondir="/var/spool/anacron"
+ keepdir ${anacrondir}
+ fowners root:cron ${anacrondir}
+ fperms 0750 ${anacrondir}
+
+ insinto /etc
+ doins contrib/anacrontab
+
+ insinto /etc/cron.hourly
+ doins contrib/0anacron
+ fperms 0750 /etc/cron.hourly/0anacron
+
+ insinto /etc/cron.d
+ doins contrib/0hourly
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+
+ if [[ -n "${REPLACING_VERSIONS}" ]] ; then
+ ewarn "You should restart ${PN} daemon or else you might experience segfaults"
+ ewarn "or ${PN} not working reliably anymore."
+ einfo "(see https://bugs.gentoo.org/557406 for details.)"
+ fi
+}
diff --git a/sys-process/cronie/files/cronie-1.3-initd b/sys-process/cronie/files/cronie-1.3-initd
index 793e6213bfae..def72818357c 100644
--- a/sys-process/cronie/files/cronie-1.3-initd
+++ b/sys-process/cronie/files/cronie-1.3-initd
@@ -4,7 +4,7 @@
command="/usr/sbin/crond"
command_args="${CRONDARGS}"
-pidfile="/var/run/crond.pid"
+pidfile="/run/crond.pid"
depend() {
use clock logger