summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-28 02:58:07 +0100
committerSam James <sam@gentoo.org>2022-10-28 02:58:19 +0100
commit812e4a387f47eac3a832690655cbceffa51aab18 (patch)
tree6a679cff7631f1193721a63ba40b0ab5a798dd6c /sys-process/procps
parentsys-devel/flex: drop obsolete cross malloc workaround (diff)
downloadgentoo-812e4a387f47eac3a832690655cbceffa51aab18.tar.gz
gentoo-812e4a387f47eac3a832690655cbceffa51aab18.tar.bz2
gentoo-812e4a387f47eac3a832690655cbceffa51aab18.zip
sys-process/procps: drop obsolete cross malloc workaround
We set the right bits in crossdev for musl targets now and, in theory, while unlikely, it is possible that some cross targets don't have the right behaviour anyway (not that i'm aware of any in use). Bug: https://bugs.gentoo.org/705800 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/procps')
-rw-r--r--sys-process/procps/procps-3.3.17-r1.ebuild13
1 files changed, 2 insertions, 11 deletions
diff --git a/sys-process/procps/procps-3.3.17-r1.ebuild b/sys-process/procps/procps-3.3.17-r1.ebuild
index 79ab60beefd1..8761ccfd17e1 100644
--- a/sys-process/procps/procps-3.3.17-r1.ebuild
+++ b/sys-process/procps/procps-3.3.17-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# See https://bugs.gentoo.org/835813 before bumping to 4.x!
-inherit flag-o-matic multilib-minimal toolchain-funcs usr-ldscript
+inherit flag-o-matic multilib-minimal usr-ldscript
DESCRIPTION="Standard informational utilities and process-handling tools"
HOMEPAGE="http://procps-ng.sourceforge.net/ https://gitlab.com/procps-ng/procps"
@@ -53,18 +53,9 @@ src_prepare() {
}
multilib_src_configure() {
- if tc-is-cross-compiler ; then
- # This isn't ideal but upstream don't provide a placement
- # when malloc is missing anyway, leading to errors like:
- # pslog.c:(.text.startup+0x108): undefined reference to `rpl_malloc'
- # See https://sourceforge.net/p/psmisc/bugs/71/
- # (and https://lists.gnu.org/archive/html/autoconf/2011-04/msg00019.html)
- export ac_cv_func_malloc_0_nonnull=yes \
- ac_cv_func_realloc_0_nonnull=yes
- fi
-
# http://www.freelists.org/post/procps/PATCH-enable-transparent-large-file-support
append-lfs-flags #471102
+
local myeconfargs=(
$(multilib_native_use_with elogind) # No elogind multilib support
$(multilib_native_use_enable kill)