summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Fabrizio Orsi <torsi@fi.uba.ar>2023-09-05 22:25:44 -0300
committerMike Gilbert <floppym@gentoo.org>2023-09-06 13:09:34 -0400
commit04c6c36e2595064c41d0ce706fba50e65ffdd5e2 (patch)
treee2cf1c25f636bac78bcaa2f9becfc43c87d87c74 /sys-process/cronbase/cronbase-0.3.7-r10.ebuild
parentdev-python/pytest-aiohttp: Bump to 1.0.5 (diff)
downloadgentoo-04c6c36e2595064c41d0ce706fba50e65ffdd5e2.tar.gz
gentoo-04c6c36e2595064c41d0ce706fba50e65ffdd5e2.tar.bz2
gentoo-04c6c36e2595064c41d0ce706fba50e65ffdd5e2.zip
sys-process/cronbase: Updated wiki from No_homepage to Cron
Signed-off-by: Tomas Fabrizio Orsi <torsi@fi.uba.ar> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-process/cronbase/cronbase-0.3.7-r10.ebuild')
-rw-r--r--sys-process/cronbase/cronbase-0.3.7-r10.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-process/cronbase/cronbase-0.3.7-r10.ebuild b/sys-process/cronbase/cronbase-0.3.7-r10.ebuild
new file mode 100644
index 000000000000..71791b7ee3dd
--- /dev/null
+++ b/sys-process/cronbase/cronbase-0.3.7-r10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Base for all cron ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Cron"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+DEPEND="acct-group/cron"
+RDEPEND="
+ ${DEPEND}
+ acct-user/cron
+"
+
+src_install() {
+ newsbin "${FILESDIR}"/run-crons-${PV} run-crons
+
+ diropts -m0750
+ keepdir /etc/cron.{hourly,daily,weekly,monthly}
+
+ keepdir /var/spool/cron/lastrun
+}