summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-17 23:00:21 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-17 23:00:53 +0200
commitfcfb0d1d391e9750bc55e9f067f494cbbd120a99 (patch)
treeba956f17fe79f562c78419bffda0e451c8167bb7 /sys-libs
parentsys-libs/compiler-rt-sanitizers: Use BDEPEND semi-properly (diff)
downloadgentoo-fcfb0d1d391e9750bc55e9f067f494cbbd120a99.tar.gz
gentoo-fcfb0d1d391e9750bc55e9f067f494cbbd120a99.tar.bz2
gentoo-fcfb0d1d391e9750bc55e9f067f494cbbd120a99.zip
sys-libs/compiler-rt: Use BDEPEND semi-properly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild3
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9.0.0.9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
index b6bc66629c35..13a5397acde0 100644
--- a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
@@ -26,7 +26,8 @@ RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
# llvm-6 for new lit options
DEPEND="
- >=sys-devel/llvm-6
+ >=sys-devel/llvm-6"
+BDEPEND="
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep "dev-python/lit[\${PYTHON_USEDEP}]")
diff --git a/sys-libs/compiler-rt/compiler-rt-9.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9.0.0.9999.ebuild
index 3b0033468a96..88bfd8aa0ad2 100644
--- a/sys-libs/compiler-rt/compiler-rt-9.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9.0.0.9999.ebuild
@@ -27,7 +27,8 @@ RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
# llvm-6 for new lit options
DEPEND="
- >=sys-devel/llvm-6
+ >=sys-devel/llvm-6"
+BDEPEND="
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep "dev-python/lit[\${PYTHON_USEDEP}]")