summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-28 15:22:45 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-28 15:25:53 -0500
commitdb548619f2d5a39f8bb523c60e99d20cf84ef513 (patch)
treee62c7ff387d7ed26d002ce4fadcd3c69f69e28f6 /sys-libs
parentfixing wxgtk dep (diff)
downloadgentoo-db548619f2d5a39f8bb523c60e99d20cf84ef513.tar.gz
gentoo-db548619f2d5a39f8bb523c60e99d20cf84ef513.tar.bz2
gentoo-db548619f2d5a39f8bb523c60e99d20cf84ef513.zip
sys-libs/db: move -Wl,--default-symver back after tc-ld-is-gold #566942
The GNU gold test will fail if given invalid linker flags, so make sure we test for it before adding various linker flags (that assume bfd).
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/db-4.8.30-r2.ebuild16
-rw-r--r--sys-libs/db/db-5.3.28-r2.ebuild16
-rw-r--r--sys-libs/db/db-6.0.30-r1.ebuild16
-rw-r--r--sys-libs/db/db-6.0.35.ebuild16
-rw-r--r--sys-libs/db/db-6.1.26.ebuild16
5 files changed, 30 insertions, 50 deletions
diff --git a/sys-libs/db/db-4.8.30-r2.ebuild b/sys-libs/db/db-4.8.30-r2.ebuild
index abb91dec4812..e556706b2c02 100644
--- a/sys-libs/db/db-4.8.30-r2.ebuild
+++ b/sys-libs/db/db-4.8.30-r2.ebuild
@@ -88,16 +88,6 @@ src_prepare() {
-e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure || die
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -110,6 +100,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(
diff --git a/sys-libs/db/db-5.3.28-r2.ebuild b/sys-libs/db/db-5.3.28-r2.ebuild
index fa3f8d6be49f..937d045c4164 100644
--- a/sys-libs/db/db-5.3.28-r2.ebuild
+++ b/sys-libs/db/db-5.3.28-r2.ebuild
@@ -103,16 +103,6 @@ src_prepare() {
done
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -125,6 +115,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(
diff --git a/sys-libs/db/db-6.0.30-r1.ebuild b/sys-libs/db/db-6.0.30-r1.ebuild
index 64433d238606..8192bec05d4e 100644
--- a/sys-libs/db/db-6.0.30-r1.ebuild
+++ b/sys-libs/db/db-6.0.30-r1.ebuild
@@ -104,16 +104,6 @@ src_prepare() {
done
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -126,6 +116,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(
diff --git a/sys-libs/db/db-6.0.35.ebuild b/sys-libs/db/db-6.0.35.ebuild
index 357f5ac8131d..6fcfe907e32b 100644
--- a/sys-libs/db/db-6.0.35.ebuild
+++ b/sys-libs/db/db-6.0.35.ebuild
@@ -104,16 +104,6 @@ src_prepare() {
done
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -126,6 +116,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(
diff --git a/sys-libs/db/db-6.1.26.ebuild b/sys-libs/db/db-6.1.26.ebuild
index 22cf36f227a6..4e9a232205de 100644
--- a/sys-libs/db/db-6.1.26.ebuild
+++ b/sys-libs/db/db-6.1.26.ebuild
@@ -104,16 +104,6 @@ src_prepare() {
done
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -126,6 +116,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(