summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-09-23 22:24:30 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-09-23 22:25:13 +0200
commita9886972c64a836852369c5fabe4581bbc7402e0 (patch)
treeafc50f7a05982af2f7e505a3a2d0fb59e75952c9 /sys-libs
parentsys-fs/zfs: remove unused patch (diff)
downloadgentoo-a9886972c64a836852369c5fabe4581bbc7402e0.tar.gz
gentoo-a9886972c64a836852369c5fabe4581bbc7402e0.tar.bz2
gentoo-a9886972c64a836852369c5fabe4581bbc7402e0.zip
sys-libs/glibc: Remember across phases if we need to force gcc
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.35-r10.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.36-r3.ebuild5
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild5
3 files changed, 15 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.35-r10.ebuild b/sys-libs/glibc/glibc-2.35-r10.ebuild
index 0395750a45d4..bf55284796ae 100644
--- a/sys-libs/glibc/glibc-2.35-r10.ebuild
+++ b/sys-libs/glibc/glibc-2.35-r10.ebuild
@@ -529,7 +529,12 @@ setup_env() {
export __ORIG_CXX=${CXX}
if tc-is-clang && ! use custom-cflags && ! is_crosscompile ; then
+ export glibc__force_gcc=yes
+ # once this is toggled on, it needs to stay on, since with CPP manipulated
+ # tc-is-clang does not work correctly anymore...
+ fi
+ if [[ ${glibc__force_gcc} == "yes" ]] ; then
# If we are running in an otherwise clang/llvm environment, we need to
# recover the proper gcc and binutils settings here, at least until glibc
# is finally building with clang. So let's override everything that is
diff --git a/sys-libs/glibc/glibc-2.36-r3.ebuild b/sys-libs/glibc/glibc-2.36-r3.ebuild
index 4910c60fc2c5..012d6984dd74 100644
--- a/sys-libs/glibc/glibc-2.36-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.36-r3.ebuild
@@ -539,7 +539,12 @@ setup_env() {
export glibc__ORIG_CXX=${CXX}
if tc-is-clang && ! use custom-cflags && ! is_crosscompile ; then
+ export glibc__force_gcc=yes
+ # once this is toggled on, it needs to stay on, since with CPP manipulated
+ # tc-is-clang does not work correctly anymore...
+ fi
+ if [[ ${glibc__force_gcc} == "yes" ]] ; then
# If we are running in an otherwise clang/llvm environment, we need to
# recover the proper gcc and binutils settings here, at least until glibc
# is finally building with clang. So let's override everything that is
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index a2e792581064..8456c2a16fe4 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -540,7 +540,12 @@ setup_env() {
export glibc__ORIG_CXX=${CXX}
if tc-is-clang && ! use custom-cflags && ! is_crosscompile ; then
+ export glibc__force_gcc=yes
+ # once this is toggled on, it needs to stay on, since with CPP manipulated
+ # tc-is-clang does not work correctly anymore...
+ fi
+ if [[ ${glibc__force_gcc} == "yes" ]] ; then
# If we are running in an otherwise clang/llvm environment, we need to
# recover the proper gcc and binutils settings here, at least until glibc
# is finally building with clang. So let's override everything that is