summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 13:23:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 14:03:12 +0100
commit94e18f2e6f41b55aa5d2b9846b539d1b093c54c4 (patch)
tree0241b0b582dad4e11f865740d8537df9459ea566 /sys-libs/libavc1394
parentx11-wm/fluxbox: kill obsolete blockers (diff)
downloadgentoo-94e18f2e6f41b55aa5d2b9846b539d1b093c54c4.tar.gz
gentoo-94e18f2e6f41b55aa5d2b9846b539d1b093c54c4.tar.bz2
gentoo-94e18f2e6f41b55aa5d2b9846b539d1b093c54c4.zip
sys-libs/libavc1394: EAPI-7 bump, autotools-multilib--
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-libs/libavc1394')
-rw-r--r--sys-libs/libavc1394/libavc1394-0.5.4-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-libs/libavc1394/libavc1394-0.5.4-r2.ebuild b/sys-libs/libavc1394/libavc1394-0.5.4-r2.ebuild
new file mode 100644
index 000000000000..402a774d3c9d
--- /dev/null
+++ b/sys-libs/libavc1394/libavc1394-0.5.4-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Library for the 1394 AV/C (Audio/Video Control) Digital Interface Command Set"
+HOMEPAGE="https://sourceforge.net/projects/libavc1394/"
+SRC_URI="mirror://sourceforge/libavc1394/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND="virtual/pkgconfig[${MULTILIB_USEDEP}]"
+DEPEND=">=sys-libs/libraw1394-2.1.0-r1[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf --disable-static
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -type f -delete || die
+}