summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-10-01 20:49:51 -0400
committerMike Pagano <mpagano@gentoo.org>2023-10-01 20:49:51 -0400
commit4333aa4e7765f94c5cd894ae8f6ad2ca34240a8c (patch)
treecd86e247e1d77460e4141c29854b8cd19f82fb51 /sys-kernel
parentapp-text/jabref-bin: drop 4.9999 (diff)
downloadgentoo-4333aa4e7765f94c5cd894ae8f6ad2ca34240a8c.tar.gz
gentoo-4333aa4e7765f94c5cd894ae8f6ad2ca34240a8c.tar.bz2
gentoo-4333aa4e7765f94c5cd894ae8f6ad2ca34240a8c.zip
sys-kernel/git-sources: add 6.6_rc4
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.6_rc4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 7cce71b32607..008f6c00d996 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-6.5.tar.xz 138898084 BLAKE2B 2e641b79a080e8f4ce283bcf6b74e2c6f15a3743
DIST patch-6.6-rc1.patch 39118113 BLAKE2B 8301642b0c12def7ee0e49a23876a3a106b345bb7877d0b9a4fd644dc6af69826bbc50028a93bb6f951b17c5d3be290e8d36a69ca765637a4b689bdb9430a672 SHA512 7d9fe9f89b8ad875ca57ccb1730ae4e853c36ef4e47d31d1d91488461e4a37c49b54b4ca5036c6c9ec7ae63101e56b06a3386a7784ae8173b6fae4a7e87e7977
DIST patch-6.6-rc2.patch 39377615 BLAKE2B 1a3ec1d61c620a29678140eb7d85ea13e40f4603fae73d77ef6695114a9cf9c65093dfab2ff3c3ca2c8ed9a86a915c60cef8726a088fe0a6af0363c53a1317a4 SHA512 4a7c6ef50493bb8fcacaf662430c3117ba373c739bd14e68d7c218aeae18de1445fea1747cbf948162399ca4227c51679d256a12e5940890ac1ddd6b37b283b8
DIST patch-6.6-rc3.patch 39738774 BLAKE2B 0a49e4735de5f24d9cc6c898834b4c1d8fc947a8adb9ea2bf31c1c0429156b78a7762707f83313173b7be9a9b5290d54e0e4be95422faab6649247e96834a846 SHA512 462bd85d7d513ef4a047d3128309a3a220d622ff10928a62f2e2cc1a57dd0186ab4afe44e19c7b96d812b63ce544edb0f34dac153d48b5c8e97ad07870a6ebf5
+DIST patch-6.6-rc4.patch 39983583 BLAKE2B 4ea2b64498c246b579f50b00b184203a86c17f3c22df052136459cd3e55dea8c8ebfcd6385251ebc6d8d9903bbd410faca9cf2efd1618c601ea3bd90653b667f SHA512 e5b18ad99c2d11d9d1f9506314bfd2356135730071f4299ac97bd1d868419fc04cb036dae2b8430adb416bc58b8bf618a6d86a01f4e07421dc9ea93b84e1e6d4
diff --git a/sys-kernel/git-sources/git-sources-6.6_rc4.ebuild b/sys-kernel/git-sources/git-sources-6.6_rc4.ebuild
new file mode 100644
index 000000000000..5065c9cfd114
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.6_rc4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.5"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}