summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-22 02:17:19 +0100
committerSam James <sam@gentoo.org>2021-09-22 02:19:16 +0100
commitbb93f0a6faaed5028794f7aaebc5644eb6ca8af5 (patch)
tree4a402fa40850ef88cf72162e9fe3e282ac966dd4 /sys-fs
parentsys-fs/zfs-kmod: add 2.0.6 (diff)
downloadgentoo-bb93f0a6faaed5028794f7aaebc5644eb6ca8af5.tar.gz
gentoo-bb93f0a6faaed5028794f7aaebc5644eb6ca8af5.tar.bz2
gentoo-bb93f0a6faaed5028794f7aaebc5644eb6ca8af5.zip
sys-fs/zfs: disable systemd on musl
Needed to fix build failures on musl (where we don't have systemd anyway): ``` zfs-mount-generator.c: In function 'line_worker': zfs-mount-generator.c:238:24: warning: implicit declaration of function 'strndupa'; did you mean 'strndup'? [-Wimplicit-function-declaration] 238 | pool = strndupa(pool, toktmp - pool); | ^~~~~~~~ | strndup zfs-mount-generator.c:238:22: warning: assignment to 'const char *' from 'int' makes pointer from integer without a cast [-Wint-conversion] 238 | pool = strndupa(pool, toktmp - pool); | ^ ``` Reported-by: Jory A. Pratt <anarchy@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs/zfs-2.1.0-r1.ebuild4
-rw-r--r--sys-fs/zfs/zfs-2.1.1-r1.ebuild5
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild5
3 files changed, 12 insertions, 2 deletions
diff --git a/sys-fs/zfs/zfs-2.1.0-r1.ebuild b/sys-fs/zfs/zfs-2.1.0-r1.ebuild
index 9f8ac5af2207..2ab356846cf3 100644
--- a/sys-fs/zfs/zfs-2.1.0-r1.ebuild
+++ b/sys-fs/zfs/zfs-2.1.0-r1.ebuild
@@ -54,6 +54,10 @@ BDEPEND="virtual/awk
nls? ( sys-devel/gettext )
python? (
dev-python/setuptools[${PYTHON_USEDEP}]
+ || (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/distlib[${PYTHON_USEDEP}]
+ )
)
"
diff --git a/sys-fs/zfs/zfs-2.1.1-r1.ebuild b/sys-fs/zfs/zfs-2.1.1-r1.ebuild
index e1514c972f16..b18fbb260614 100644
--- a/sys-fs/zfs/zfs-2.1.1-r1.ebuild
+++ b/sys-fs/zfs/zfs-2.1.1-r1.ebuild
@@ -180,7 +180,6 @@ src_configure() {
local myconf=(
--bindir="${EPREFIX}/bin"
--enable-shared
- --enable-systemd
--enable-sysvinit
--localstatedir="${EPREFIX}/var"
--sbindir="${EPREFIX}/sbin"
@@ -194,6 +193,10 @@ src_configure() {
--with-systemdunitdir="$(systemd_get_systemunitdir)"
--with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
--with-vendor=gentoo
+ # Building zfs-mount-generator.c on musl breaks as strndupa
+ # isn't available. But systemd doesn't support musl anyway, so
+ # just disable building it.
+ $(use_enable !elibc_musl systemd)
$(use_enable debug)
$(use_enable nls)
$(use_enable pam)
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 10db2b452cba..43755044ed6b 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -182,7 +182,6 @@ src_configure() {
local myconf=(
--bindir="${EPREFIX}/bin"
--enable-shared
- --enable-systemd
--enable-sysvinit
--localstatedir="${EPREFIX}/var"
--sbindir="${EPREFIX}/sbin"
@@ -196,6 +195,10 @@ src_configure() {
--with-systemdunitdir="$(systemd_get_systemunitdir)"
--with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
--with-vendor=gentoo
+ # Building zfs-mount-generator.c on musl breaks as strndupa
+ # isn't available. But systemd doesn't support musl anyway, so
+ # just disable building it.
+ $(use_enable !elibc_musl systemd)
$(use_enable debug)
$(use_enable nls)
$(use_enable pam)