summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-04-13 14:05:21 -0400
committerMike Gilbert <floppym@gentoo.org>2024-04-13 14:12:21 -0400
commita61d44c66bf643f46e1b23514430feacf739ff4e (patch)
tree31ba4c6af1afe040fa5e45ee3c9824ed62af43b2 /sys-fs
parentdev-lang/php: Stabilize 8.2.18 arm, #929928 (diff)
downloadgentoo-a61d44c66bf643f46e1b23514430feacf739ff4e.tar.gz
gentoo-a61d44c66bf643f46e1b23514430feacf739ff4e.tar.bz2
gentoo-a61d44c66bf643f46e1b23514430feacf739ff4e.zip
sys-fs/fuse: improve test phase
Set PROPERTIES="test_privileged". Add missing test dep. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/fuse-3.16.2.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/sys-fs/fuse/fuse-3.16.2.ebuild b/sys-fs/fuse/fuse-3.16.2.ebuild
index 10840ae807b0..ff659036c273 100644
--- a/sys-fs/fuse/fuse-3.16.2.ebuild
+++ b/sys-fs/fuse/fuse-3.16.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,13 +14,15 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="3"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="+suid test"
-RESTRICT="!test? ( test ) test? ( userpriv )"
+RESTRICT="!test? ( test )"
+PROPERTIES="test_privileged"
BDEPEND="
virtual/pkgconfig
test? (
${PYTHON_DEPS}
$(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ $(python_gen_any_dep 'dev-python/looseversion[${PYTHON_USEDEP}]')
)
"
RDEPEND=">=sys-fs/fuse-common-3.3.0-r1"
@@ -28,7 +30,8 @@ RDEPEND=">=sys-fs/fuse-common-3.3.0-r1"
DOCS=( AUTHORS ChangeLog.rst README.md doc/README.NFS doc/kernel.txt )
python_check_deps() {
- python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/looseversion[${PYTHON_USEDEP}]"
}
pkg_setup() {
@@ -50,11 +53,11 @@ multilib_src_configure() {
}
src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "Sandbox enabled, skipping tests"
- else
+ (
+ addwrite /dev/cuse
+ addwrite /dev/fuse
multilib-minimal_src_test
- fi
+ ) || die
}
multilib_src_test() {