summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-09-21 10:19:15 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-09-21 10:19:42 +0200
commit64e91259d4f2a7e57ab9a61084e8938b55aec6d4 (patch)
tree23ff2bca7a9c0d9bbea5c90b9807c2730818e457 /sys-fs
parentprofiles: last-rite net-misc/dahdi (and related pkgs) (diff)
downloadgentoo-64e91259d4f2a7e57ab9a61084e8938b55aec6d4.tar.gz
gentoo-64e91259d4f2a7e57ab9a61084e8938b55aec6d4.tar.bz2
gentoo-64e91259d4f2a7e57ab9a61084e8938b55aec6d4.zip
sys-fs/bcache-tools: add 1.1_p20230217
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bcache-tools/Manifest1
-rw-r--r--sys-fs/bcache-tools/bcache-tools-1.1_p20230217.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-fs/bcache-tools/Manifest b/sys-fs/bcache-tools/Manifest
index 97abfadeebf6..758c849ef533 100644
--- a/sys-fs/bcache-tools/Manifest
+++ b/sys-fs/bcache-tools/Manifest
@@ -1 +1,2 @@
DIST bcache-tools-1.1.tar.gz 34548 BLAKE2B e6ebc0f609debe0cc123deba0e21076441c37cdbc6edd02bf2c16c0e36fe806f1fc160b9e9baed577f86f6358884182a4e3903f34bccee81943191c0ba6a2d11 SHA512 4ccbef47255bf3644a50242a79951b1f3720e71a55eb1e07dc6b8486df0245da99a77bba751b50197d489b4c5d738e5284aabc014c2f7f44816ddf6a1bb807ca
+DIST bcache-tools-1.1_p20230217.tar.gz 44025 BLAKE2B c6e1c3e64d1f53f581cd6ea80b919bd7db93e0ec048de70e65cfa1b28ae59e921c7cdcf4c3d0f25823ab323f76ef29671bc2e3db616bad34e8c193aaa3a38c89 SHA512 aac047cb773ebc9e9c139f0a3da5721511a24265a497ce26fd607a26195d402ef78fa5f3c76d609195ee48267395527bd7083abe996e9fa3009b43ac85f94652
diff --git a/sys-fs/bcache-tools/bcache-tools-1.1_p20230217.ebuild b/sys-fs/bcache-tools/bcache-tools-1.1_p20230217.ebuild
new file mode 100644
index 000000000000..88fe95d15846
--- /dev/null
+++ b/sys-fs/bcache-tools/bcache-tools-1.1_p20230217.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit flag-o-matic python-r1 toolchain-funcs udev vcs-snapshot
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/colyli/bcache-tools.git https://kernel.googlesource.com/pub/scm/linux/kernel/git/colyli/bcache-tools.git"
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/colyli/${PN}.git/snapshot/a5e3753516bd39c431def86c8dfec8a9cea1ddd4.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Tools for bcache"
+HOMEPAGE="https://bcache.evilpiepirate.org/ https://git.kernel.org/pub/scm/linux/kernel/git/colyli/bcache-tools.git/"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sys-apps/util-linux
+ virtual/udev
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ tc-export CC
+ sed \
+ -e '/^CFLAGS/s:-O2::' \
+ -e '/^CFLAGS/s:-g::' \
+ -i Makefile || die
+
+ append-lfs-flags
+}
+
+src_install() {
+ into /
+ dosbin bcache make-bcache bcache-super-show
+
+ exeinto $(get_udevdir)
+ doexe bcache-register probe-bcache
+
+ python_foreach_impl python_doscript bcache-status
+
+ udev_dorules 69-bcache.rules
+
+ insinto /etc/initramfs-tools/hooks/bcache
+ doins initramfs/hook
+
+ # that is what dracut does
+ insinto /usr/lib/dracut/modules.d/90bcache
+ doins dracut/module-setup.sh
+
+ doman *.8
+
+ dodoc README
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}