summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sys-fs
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryfs/cryfs-0.10.2.ebuild1
-rw-r--r--sys-fs/cryfs/cryfs-0.9.9-r1.ebuild1
-rw-r--r--sys-fs/cryfs/cryfs-9999.ebuild1
-rw-r--r--sys-fs/dosfstools/dosfstools-4.1.ebuild1
-rw-r--r--sys-fs/eudev/eudev-3.2.5.ebuild1
-rw-r--r--sys-fs/eudev/eudev-3.2.7-r2.ebuild1
-rw-r--r--sys-fs/eudev/eudev-3.2.8.ebuild1
-rw-r--r--sys-fs/eudev/eudev-3.2.9.ebuild1
-rw-r--r--sys-fs/eudev/eudev-4.9999.ebuild1
-rw-r--r--sys-fs/eudev/eudev-9999.ebuild1
-rw-r--r--sys-fs/safecopy/safecopy-1.7.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-10.0.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-11.0-r1.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-11.2.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-6.2.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-6.3.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-7.0.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-7.1.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-8.1.ebuild3
-rw-r--r--sys-fs/tmsu/tmsu-0.6.1.ebuild3
-rw-r--r--sys-fs/tmsu/tmsu-0.7.0.ebuild3
21 files changed, 32 insertions, 11 deletions
diff --git a/sys-fs/cryfs/cryfs-0.10.2.ebuild b/sys-fs/cryfs/cryfs-0.10.2.ebuild
index 4844d38e7188..3be99d5e1469 100644
--- a/sys-fs/cryfs/cryfs-0.10.2.ebuild
+++ b/sys-fs/cryfs/cryfs-0.10.2.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://www.cryfs.org/"
LICENSE="LGPL-3 MIT"
SLOT="0"
IUSE="custom-optimization debug libressl test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/boost-1.65.1:=
diff --git a/sys-fs/cryfs/cryfs-0.9.9-r1.ebuild b/sys-fs/cryfs/cryfs-0.9.9-r1.ebuild
index d3e493e3ecb9..7465d202882d 100644
--- a/sys-fs/cryfs/cryfs-0.9.9-r1.ebuild
+++ b/sys-fs/cryfs/cryfs-0.9.9-r1.ebuild
@@ -12,6 +12,7 @@ HOMEPAGE="https://www.cryfs.org/"
SLOT=0
IUSE="custom-optimization libressl test update-check"
+RESTRICT="!test? ( test )"
LICENSE="LGPL-3 BSD-2 MIT"
# cryfs - LGPL-3
diff --git a/sys-fs/cryfs/cryfs-9999.ebuild b/sys-fs/cryfs/cryfs-9999.ebuild
index 5cd7961f3996..0201a999cbce 100644
--- a/sys-fs/cryfs/cryfs-9999.ebuild
+++ b/sys-fs/cryfs/cryfs-9999.ebuild
@@ -25,6 +25,7 @@ HOMEPAGE="https://www.cryfs.org/"
LICENSE="LGPL-3 MIT Boost-1.0"
SLOT="0"
IUSE="custom-optimization debug libressl test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/boost-1.65.1:=
diff --git a/sys-fs/dosfstools/dosfstools-4.1.ebuild b/sys-fs/dosfstools/dosfstools-4.1.ebuild
index b13192136d08..42d9bb0807ed 100644
--- a/sys-fs/dosfstools/dosfstools-4.1.ebuild
+++ b/sys-fs/dosfstools/dosfstools-4.1.ebuild
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="compat test +udev"
+RESTRICT="!test? ( test )"
CDEPEND="udev? ( virtual/libudev )"
DEPEND="${CDEPEND}
diff --git a/sys-fs/eudev/eudev-3.2.5.ebuild b/sys-fs/eudev/eudev-3.2.5.ebuild
index 292095d63780..23b3ca125196 100644
--- a/sys-fs/eudev/eudev-3.2.5.ebuild
+++ b/sys-fs/eudev/eudev-3.2.5.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )
diff --git a/sys-fs/eudev/eudev-3.2.7-r2.ebuild b/sys-fs/eudev/eudev-3.2.7-r2.ebuild
index a9b3e55a1b92..b8f4365b8521 100644
--- a/sys-fs/eudev/eudev-3.2.7-r2.ebuild
+++ b/sys-fs/eudev/eudev-3.2.7-r2.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )
diff --git a/sys-fs/eudev/eudev-3.2.8.ebuild b/sys-fs/eudev/eudev-3.2.8.ebuild
index a9b3e55a1b92..b8f4365b8521 100644
--- a/sys-fs/eudev/eudev-3.2.8.ebuild
+++ b/sys-fs/eudev/eudev-3.2.8.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )
diff --git a/sys-fs/eudev/eudev-3.2.9.ebuild b/sys-fs/eudev/eudev-3.2.9.ebuild
index e56aa608e957..3152f10509ba 100644
--- a/sys-fs/eudev/eudev-3.2.9.ebuild
+++ b/sys-fs/eudev/eudev-3.2.9.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )
diff --git a/sys-fs/eudev/eudev-4.9999.ebuild b/sys-fs/eudev/eudev-4.9999.ebuild
index da2372754cf1..ac45032c4807 100644
--- a/sys-fs/eudev/eudev-4.9999.ebuild
+++ b/sys-fs/eudev/eudev-4.9999.ebuild
@@ -23,6 +23,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 GPL-2"
SLOT="0"
IUSE="+blkid efi +hwdb +kmod selinux smack test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
kmod? ( >=sys-apps/kmod-16 )
diff --git a/sys-fs/eudev/eudev-9999.ebuild b/sys-fs/eudev/eudev-9999.ebuild
index a9b3e55a1b92..b8f4365b8521 100644
--- a/sys-fs/eudev/eudev-9999.ebuild
+++ b/sys-fs/eudev/eudev-9999.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )
diff --git a/sys-fs/safecopy/safecopy-1.7.ebuild b/sys-fs/safecopy/safecopy-1.7.ebuild
index 6f164039b078..dbfe2a87a2aa 100644
--- a/sys-fs/safecopy/safecopy-1.7.ebuild
+++ b/sys-fs/safecopy/safecopy-1.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -13,6 +13,7 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=""
DEPEND=""
diff --git a/sys-fs/snapraid/snapraid-10.0.ebuild b/sys-fs/snapraid/snapraid-10.0.ebuild
index 365a2b3e3b77..98f521f8559d 100644
--- a/sys-fs/snapraid/snapraid-10.0.ebuild
+++ b/sys-fs/snapraid/snapraid-10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,5 +11,6 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
diff --git a/sys-fs/snapraid/snapraid-11.0-r1.ebuild b/sys-fs/snapraid/snapraid-11.0-r1.ebuild
index 616bd2007353..57a03c45a1a0 100644
--- a/sys-fs/snapraid/snapraid-11.0-r1.ebuild
+++ b/sys-fs/snapraid/snapraid-11.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
diff --git a/sys-fs/snapraid/snapraid-11.2.ebuild b/sys-fs/snapraid/snapraid-11.2.ebuild
index 3784113b2d7a..35f69f087034 100644
--- a/sys-fs/snapraid/snapraid-11.2.ebuild
+++ b/sys-fs/snapraid/snapraid-11.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
diff --git a/sys-fs/snapraid/snapraid-6.2.ebuild b/sys-fs/snapraid/snapraid-6.2.ebuild
index 7ebac664aa91..97ee8d31b0c1 100644
--- a/sys-fs/snapraid/snapraid-6.2.ebuild
+++ b/sys-fs/snapraid/snapraid-6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND=""
RDEPEND="${DEPEND}"
diff --git a/sys-fs/snapraid/snapraid-6.3.ebuild b/sys-fs/snapraid/snapraid-6.3.ebuild
index 7ebac664aa91..97ee8d31b0c1 100644
--- a/sys-fs/snapraid/snapraid-6.3.ebuild
+++ b/sys-fs/snapraid/snapraid-6.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND=""
RDEPEND="${DEPEND}"
diff --git a/sys-fs/snapraid/snapraid-7.0.ebuild b/sys-fs/snapraid/snapraid-7.0.ebuild
index 4268c953a344..c8f3100ca6d2 100644
--- a/sys-fs/snapraid/snapraid-7.0.ebuild
+++ b/sys-fs/snapraid/snapraid-7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND=""
RDEPEND="${DEPEND}"
diff --git a/sys-fs/snapraid/snapraid-7.1.ebuild b/sys-fs/snapraid/snapraid-7.1.ebuild
index c4608373e996..e33402715818 100644
--- a/sys-fs/snapraid/snapraid-7.1.ebuild
+++ b/sys-fs/snapraid/snapraid-7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,5 +13,6 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
diff --git a/sys-fs/snapraid/snapraid-8.1.ebuild b/sys-fs/snapraid/snapraid-8.1.ebuild
index c4608373e996..e33402715818 100644
--- a/sys-fs/snapraid/snapraid-8.1.ebuild
+++ b/sys-fs/snapraid/snapraid-8.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,5 +13,6 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
diff --git a/sys-fs/tmsu/tmsu-0.6.1.ebuild b/sys-fs/tmsu/tmsu-0.6.1.ebuild
index d37b33711282..425fb4cc2359 100644
--- a/sys-fs/tmsu/tmsu-0.6.1.ebuild
+++ b/sys-fs/tmsu/tmsu-0.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,6 +14,7 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test zsh-completion"
+RESTRICT+=" !test? ( test )"
RDEPEND="
zsh-completion? ( app-shells/zsh )
diff --git a/sys-fs/tmsu/tmsu-0.7.0.ebuild b/sys-fs/tmsu/tmsu-0.7.0.ebuild
index d37b33711282..425fb4cc2359 100644
--- a/sys-fs/tmsu/tmsu-0.7.0.ebuild
+++ b/sys-fs/tmsu/tmsu-0.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,6 +14,7 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test zsh-completion"
+RESTRICT+=" !test? ( test )"
RDEPEND="
zsh-completion? ( app-shells/zsh )