summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-09 17:46:44 +0100
committerSam James <sam@gentoo.org>2021-08-09 17:47:07 +0100
commit36ef228ff82661f1491b6c7e532df24755992bbc (patch)
tree40819f00222b148b4ad3a9d40608774f2fa562fa /sys-fs/udev
parentgames-fps/quakeforge: pass new --disable-simd for live ebuild (diff)
downloadgentoo-36ef228ff82661f1491b6c7e532df24755992bbc.tar.gz
gentoo-36ef228ff82661f1491b6c7e532df24755992bbc.tar.bz2
gentoo-36ef228ff82661f1491b6c7e532df24755992bbc.zip
sys-fs/udev: add message when switching from sys-fs/eudev
Helpful for the musl users who will end up hitting this as a result of the unmasking of sys-fs/udev on their profiles. Bug: https://bugs.gentoo.org/807193 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/udev')
-rw-r--r--sys-fs/udev/udev-249-r2.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/sys-fs/udev/udev-249-r2.ebuild b/sys-fs/udev/udev-249-r2.ebuild
index e6d857dcefb5..5dbd7be0b71c 100644
--- a/sys-fs/udev/udev-249-r2.ebuild
+++ b/sys-fs/udev/udev-249-r2.ebuild
@@ -279,6 +279,10 @@ multilib_src_install_all() {
einstalldocs
}
+pkg_preinst() {
+ has_version 'sys-fs/eudev' && HAD_EUDEV=1
+}
+
pkg_postinst() {
# Update hwdb database in case the format is changed by udev version.
if has_version 'sys-apps/hwids[udev]' ; then
@@ -287,4 +291,13 @@ pkg_postinst() {
# https://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
[[ -z ${REPLACING_VERSIONS} ]] && udev_reload
fi
+
+ if [[ ${HAD_EUDEV} -eq 1 ]] ; then
+ ewarn
+ ewarn "${P} defaults to predictable interface renaming, as described in the URL below:"
+ ewarn "https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
+ ewarn
+ ewarn "If you wish to disable this, please see the above documentation, or set"
+ ewarn "net.ifnames=0 on the kernel command line."
+ fi
}