summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-16 22:16:19 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-16 22:16:19 +0200
commitbc310d09456377a4cbde1ec4b0bff892999bc456 (patch)
tree446001b44afad94068ac4a1f0cac6d5fc707c1a1 /sys-fs/quotatool
parentsci-chemistry/pdbcns: Port to EAPI 7 (diff)
downloadgentoo-bc310d09456377a4cbde1ec4b0bff892999bc456.tar.gz
gentoo-bc310d09456377a4cbde1ec4b0bff892999bc456.tar.bz2
gentoo-bc310d09456377a4cbde1ec4b0bff892999bc456.zip
sys-fs/quotatool: Port to EAPI 7
Closes: https://bugs.gentoo.org/725992 Closes: https://bugs.gentoo.org/740918 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fs/quotatool')
-rw-r--r--sys-fs/quotatool/files/quotatool-1.4.13-fix-buildsystem.patch (renamed from sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch)16
-rw-r--r--sys-fs/quotatool/quotatool-1.6.2.ebuild14
2 files changed, 20 insertions, 10 deletions
diff --git a/sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch b/sys-fs/quotatool/files/quotatool-1.4.13-fix-buildsystem.patch
index d73f02f8ce81..b65542988080 100644
--- a/sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch
+++ b/sys-fs/quotatool/files/quotatool-1.4.13-fix-buildsystem.patch
@@ -1,5 +1,5 @@
---- quotatool-1.4.13/local.mk.in
-+++ quotatool-1.4.13/local.mk.in
+--- a/local.mk.in
++++ b/local.mk.in
@@ -17,7 +17,8 @@
CC := @CC@
@@ -10,8 +10,8 @@
INSTALL := @INSTALL@
---- quotatool-1.4.13/Makefile
-+++ quotatool-1.4.13/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -58,7 +58,7 @@
# compile the program (and the objects)
all: $(prog)
@@ -21,3 +21,11 @@
+--- a/tools/depend.sh
++++ b/tools/depend.sh
+@@ -4,4 +4,4 @@
+ # Generated automatically from depend.sh.in by configure.
+
+ set -e
+-gcc -MM $* | sed 's#\($*\)\.o[ :]*#\1.o $@ : #g'
++${CC:-cc} -MM $* | sed 's#\($*\)\.o[ :]*#\1.o $@ : #g'
diff --git a/sys-fs/quotatool/quotatool-1.6.2.ebuild b/sys-fs/quotatool/quotatool-1.6.2.ebuild
index c71e452c4d97..1704f4c5ba47 100644
--- a/sys-fs/quotatool/quotatool-1.6.2.ebuild
+++ b/sys-fs/quotatool/quotatool-1.6.2.ebuild
@@ -1,23 +1,25 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit eutils
+inherit toolchain-funcs
-DESCRIPTION="command-line utility for filesystem quotas"
+DESCRIPTION="Command-line utility for filesystem quotas"
HOMEPAGE="http://quotatool.ekenberg.se/"
SRC_URI="http://quotatool.ekenberg.se/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE=""
RDEPEND="sys-fs/quota"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.4.13-ldflags.patch
+PATCHES=( "${FILESDIR}"/${PN}-1.4.13-fix-buildsystem.patch )
+
+src_configure() {
+ tc-export CC
+ default
}
src_install() {