summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-11-25 21:51:15 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-11-25 21:53:21 +0100
commita10afdeeb59939a8fbdd882642a352ae850839b3 (patch)
treeb0a6a180cccc8c69cba8a10cfbd5b470286f42c4 /sys-fs/fuse-zip/fuse-zip-0.7.2.ebuild
parentdev-scheme/chez: fix for ncurses detection; ncurses slot (diff)
downloadgentoo-a10afdeeb59939a8fbdd882642a352ae850839b3.tar.gz
gentoo-a10afdeeb59939a8fbdd882642a352ae850839b3.tar.bz2
gentoo-a10afdeeb59939a8fbdd882642a352ae850839b3.zip
sys-fs/fuse-zip: add 0.7.2
Closes: https://github.com/gentoo/gentoo/pull/16422 Closes: https://bugs.gentoo.org/759559 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-fs/fuse-zip/fuse-zip-0.7.2.ebuild')
-rw-r--r--sys-fs/fuse-zip/fuse-zip-0.7.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/fuse-zip/fuse-zip-0.7.2.ebuild b/sys-fs/fuse-zip/fuse-zip-0.7.2.ebuild
new file mode 100644
index 000000000000..0d37e30e5f07
--- /dev/null
+++ b/sys-fs/fuse-zip/fuse-zip-0.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="FUSE file system to navigate, extract, create and modify ZIP archives"
+HOMEPAGE="https://bitbucket.org/agalanin/fuse-zip"
+SRC_URI="https://bitbucket.org/agalanin/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/libzip:=
+ sys-fs/fuse:0
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( changelog README.md )
+
+PATCHES=( "${FILESDIR}/${PN}-0.4.5-makefile.patch" )
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ default
+ doman fuse-zip.1
+}