summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-30 11:57:39 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-30 11:57:50 +0100
commit55211db471467eb9e89666db17a299fc3a9ae2bf (patch)
tree55ee85b6c0e772bdceed01610555b4b09da3dfce /sys-fs/e2fsprogs/files
parentsys-libs/e2fsprogs-libs: Bump to version 1.46.0 (diff)
downloadgentoo-55211db471467eb9e89666db17a299fc3a9ae2bf.tar.gz
gentoo-55211db471467eb9e89666db17a299fc3a9ae2bf.tar.bz2
gentoo-55211db471467eb9e89666db17a299fc3a9ae2bf.zip
sys-fs/e2fsprogs: Bump to version 1.46.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/e2fsprogs/files')
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.46.0-pthreads_build.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.46.0-pthreads_build.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.46.0-pthreads_build.patch
new file mode 100644
index 000000000000..9d251d2f0b37
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.46.0-pthreads_build.patch
@@ -0,0 +1,46 @@
+From 24487a7fa64bfa92bea21be3ca8c155e5de7438f Mon Sep 17 00:00:00 2001
+From: Theodore Ts'o <tytso@mit.edu>
+Date: Fri, 29 Jan 2021 22:28:31 -0500
+Subject: configure.ac: fix build failure on systems with pthreads && !fuse
+ support
+
+The configure script checks for pthread.h as part of double-checking
+that the FUSE support works correctly, which implicitly defined
+HAVE_PHREAD_H. If the FUSE libraries are not present (or fuse support
+is explicitly disabled), this check doesn't happen and so
+HAVE_PTHREAD_H is not defined, and this causes a build failure.
+
+Signed-off-by: Theodore Ts'o <tytso@mit.edu>
+---
+ configure | 2 +-
+ configure.ac | 1 +
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index 9d41d069..6b8b7f4b 100755
+--- a/configure
++++ b/configure
+@@ -10448,7 +10448,7 @@ fi
+ done
+
+ fi
+-for ac_header in dirent.h errno.h execinfo.h getopt.h malloc.h mntent.h paths.h semaphore.h setjmp.h signal.h stdarg.h stdint.h stdlib.h termios.h termio.h unistd.h utime.h attr/xattr.h linux/falloc.h linux/fd.h linux/fsmap.h linux/major.h linux/loop.h linux/types.h net/if_dl.h netinet/in.h sys/acl.h sys/disklabel.h sys/disk.h sys/file.h sys/ioctl.h sys/key.h sys/mkdev.h sys/mman.h sys/mount.h sys/prctl.h sys/resource.h sys/select.h sys/socket.h sys/sockio.h sys/stat.h sys/syscall.h sys/sysmacros.h sys/time.h sys/types.h sys/un.h sys/wait.h sys/xattr.h
++for ac_header in dirent.h errno.h execinfo.h getopt.h malloc.h mntent.h paths.h pthread.h semaphore.h setjmp.h signal.h stdarg.h stdint.h stdlib.h termios.h termio.h unistd.h utime.h attr/xattr.h linux/falloc.h linux/fd.h linux/fsmap.h linux/major.h linux/loop.h linux/types.h net/if_dl.h netinet/in.h sys/acl.h sys/disklabel.h sys/disk.h sys/file.h sys/ioctl.h sys/key.h sys/mkdev.h sys/mman.h sys/mount.h sys/prctl.h sys/resource.h sys/select.h sys/socket.h sys/sockio.h sys/stat.h sys/syscall.h sys/sysmacros.h sys/time.h sys/types.h sys/un.h sys/wait.h sys/xattr.h
+ do :
+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
+diff --git a/configure.ac b/configure.ac
+index 141c4d9c..42b6f486 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -975,6 +975,7 @@ AC_CHECK_HEADERS(m4_flatten([
+ malloc.h
+ mntent.h
+ paths.h
++ pthread.h
+ semaphore.h
+ setjmp.h
+ signal.h
+--
+cgit 1.2.3-1.el7
+