summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-21 23:24:31 +0000
committerSam James <sam@gentoo.org>2022-01-21 23:42:59 +0000
commit5bad5a170adc6e83b7943d7469b69535a6aee886 (patch)
treeda956d457be30f6c0b51107137be85b474b907a7 /sys-devel
parentnet-misc/youtube-viewer: sync live (diff)
downloadgentoo-5bad5a170adc6e83b7943d7469b69535a6aee886.tar.gz
gentoo-5bad5a170adc6e83b7943d7469b69535a6aee886.tar.bz2
gentoo-5bad5a170adc6e83b7943d7469b69535a6aee886.zip
sys-devel/binutils: respect CFLAGS for PGO
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-2.37_p1-r2.ebuild5
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/sys-devel/binutils/binutils-2.37_p1-r2.ebuild b/sys-devel/binutils/binutils-2.37_p1-r2.ebuild
index c7c57aefb044..bbcd261cef45 100644
--- a/sys-devel/binutils/binutils-2.37_p1-r2.ebuild
+++ b/sys-devel/binutils/binutils-2.37_p1-r2.ebuild
@@ -275,6 +275,11 @@ src_configure() {
$(use_enable pgo pgo-build lto)
)
+
+ if use pgo ; then
+ export BUILD_CFLAGS="${CFLAGS}"
+ fi
+
echo ./configure "${myconf[@]}"
"${S}"/configure "${myconf[@]}" || die
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index d53c8d446235..d79e91c3cff1 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -276,6 +276,11 @@ src_configure() {
$(use_enable pgo pgo-build lto)
)
+
+ if use pgo ; then
+ export BUILD_CFLAGS="${CFLAGS}"
+ fi
+
echo ./configure "${myconf[@]}"
"${S}"/configure "${myconf[@]}" || die