summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-01 11:31:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-01 11:37:05 +0200
commit1410d3d4203c9cd9de042d3f435d396019fe65bc (patch)
tree677250d304f30464485838eb7416292c9cefaae8 /sys-devel
parentmedia-sound/alacenc: fix musl build (diff)
downloadgentoo-1410d3d4203c9cd9de042d3f435d396019fe65bc.tar.gz
gentoo-1410d3d4203c9cd9de042d3f435d396019fe65bc.tar.bz2
gentoo-1410d3d4203c9cd9de042d3f435d396019fe65bc.zip
sys-devel/llvm: libtinfo (ncurses) is no longer used
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-19.0.0.9999.ebuild8
1 files changed, 1 insertions, 7 deletions
diff --git a/sys-devel/llvm/llvm-19.0.0.9999.ebuild b/sys-devel/llvm/llvm-19.0.0.9999.ebuild
index ec5c511745fc..c4930d262794 100644
--- a/sys-devel/llvm/llvm-19.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-19.0.0.9999.ebuild
@@ -21,7 +21,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA BSD public-domain rc"
SLOT="${LLVM_MAJOR}/${LLVM_SOABI}"
IUSE="
+binutils-plugin +debug debuginfod doc exegesis libedit +libffi
- ncurses test xml z3 zstd
+ test xml z3 zstd
"
RESTRICT="!test? ( test )"
@@ -34,7 +34,6 @@ RDEPEND="
exegesis? ( dev-libs/libpfm:= )
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=dev-libs/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
- ncurses? ( >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}] )
xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )
zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
@@ -386,7 +385,6 @@ multilib_src_configure() {
-DLLVM_ENABLE_FFI=$(usex libffi)
-DLLVM_ENABLE_LIBEDIT=$(usex libedit)
- -DLLVM_ENABLE_TERMINFO=$(usex ncurses)
-DLLVM_ENABLE_LIBXML2=$(usex xml)
-DLLVM_ENABLE_ASSERTIONS=$(usex debug)
-DLLVM_ENABLE_LIBPFM=$(usex exegesis)
@@ -456,10 +454,6 @@ multilib_src_configure() {
fi
use kernel_Darwin && mycmakeargs+=(
- # On Macos prefix, Gentoo doesn't split sys-libs/ncurses to libtinfo and
- # libncurses, but llvm tries to use libtinfo before libncurses, and ends up
- # using libtinfo (actually, libncurses.dylib) from system instead of prefix
- -DTerminfo_LIBRARIES=-lncurses
# Use our libtool instead of looking it up with xcrun
-DCMAKE_LIBTOOL="${EPREFIX}/usr/bin/${CHOST}-libtool"
)