summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 07:08:26 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:43:57 +0100
commitb04baf10c2982ecdb205e1f32d9b05ecb8e7fa67 (patch)
tree78eec2f36f8f0402c8b06098e20c4b53c86af62f /sys-cluster
parentsys-cluster/lustre: fix variable references (diff)
downloadgentoo-b04baf10c2982ecdb205e1f32d9b05ecb8e7fa67.tar.gz
gentoo-b04baf10c2982ecdb205e1f32d9b05ecb8e7fa67.tar.bz2
gentoo-b04baf10c2982ecdb205e1f32d9b05ecb8e7fa67.zip
sys-cluster/openmpi: fix variable references
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild b/sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild
index c5a6122cbd99..2a01a1f2fb30 100644
--- a/sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.7.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ inherit autotools cuda flag-o-matic fortran-2 toolchain-funcs
MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}"/${MY_P}
IUSE_OPENMPI_FABRICS="
openmpi_fabrics_ofed
@@ -131,7 +131,7 @@ src_configure() {
econf "${myconf[@]}" \
$(use_enable cxx mpi-cxx) \
$(use_with cma) \
- $(use_with cuda cuda "$EPREFIX"/opt/cuda) \
+ $(use_with cuda cuda "${EPREFIX}"/opt/cuda) \
$(use_enable romio io-romio) \
$(use_enable heterogeneous) \
$(use_enable ipv6) \
@@ -149,8 +149,10 @@ src_configure() {
src_install() {
default
+
# From USE=vt see #359917
rm "${ED}"/usr/share/libtool || die
+
# Avoid collisions with libevent
rm -rf "${ED}"/usr/include/event2 || die
dodoc README AUTHORS NEWS VERSION