summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2019-07-07 07:46:28 +0100
committerJustin Lecher <jlec@gentoo.org>2019-07-07 07:49:07 +0100
commitda00598904de34d68c2b62fdb343246cda5a4be5 (patch)
tree9b7e9fc2438ea182628acc76cfd43cadd7b36c99 /sys-cluster/ucx
parentsys-fs/aufs-util: Version Bump (diff)
downloadgentoo-da00598904de34d68c2b62fdb343246cda5a4be5.tar.gz
gentoo-da00598904de34d68c2b62fdb343246cda5a4be5.tar.bz2
gentoo-da00598904de34d68c2b62fdb343246cda5a4be5.zip
sys-cluster/ucx: Version Bump
Package-Manager: Portage-2.3.68, Repoman-2.3.12 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-cluster/ucx')
-rw-r--r--sys-cluster/ucx/Manifest1
-rw-r--r--sys-cluster/ucx/ucx-1.5.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-cluster/ucx/Manifest b/sys-cluster/ucx/Manifest
index 6382831bd8a8..8c6528f41370 100644
--- a/sys-cluster/ucx/Manifest
+++ b/sys-cluster/ucx/Manifest
@@ -1,2 +1,3 @@
DIST ucx-1.2.2.tar.gz 1513611 BLAKE2B 488b9b3cecc2c617b1209036e1342e4378459db6a5e93eab1d88dfe80cb0d9c8013c767413206f0fbd0105557ed89994ab510421068d709101336a7b3d2eac5e SHA512 515c382826310b9aa7179ab19ceb76a881a41e6786514219b7f703c6144fa57ca141bceb3b80523ae1b4e2a4b13e9abcb9df063612b376d894c5cd81cdc00571
DIST ucx-1.3.0.tar.gz 1707317 BLAKE2B 740ab240663a26fde8abe631416dae6233febf3c587ba6bb7b27a9cb0aa041540ce71e106bb3c5618a719de66d479055961908b67125df61a4c7696999c0affb SHA512 0a2e32985e0225fc4ad15dbb1c422dba1d5552638e7329d67572924502e61e1a481ce30cde5ccc83c663fb4ec643df83efc08aed164dfbce6cf38d66a16b3e42
+DIST ucx-1.5.2.tar.gz 1844416 BLAKE2B 2e0296e34d8116a79c545fb3371dda1746517a18cc75f94da5d1f9420c7a74752839d5a3a07a61a2e91021baa87a26d02ab24554316351db9ba76721a18a5244 SHA512 7f11014eb26df342fc8f0914d323f08f4c19ea21e98e18f0a4ec18b7004299687f91daa8ee654ecee716ece6d4d6de5c9714c548768b1d44551b6be6195e2e9b
diff --git a/sys-cluster/ucx/ucx-1.5.2.ebuild b/sys-cluster/ucx/ucx-1.5.2.ebuild
new file mode 100644
index 000000000000..55ec075ba427
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="http://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}