summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-02-03 22:18:12 -0500
committerMike Gilbert <floppym@gentoo.org>2024-02-03 22:19:14 -0500
commit46792ce3aca3b580570625dc340631f08aed998c (patch)
tree04a38eed562e0cd9f7b361e3caffe50b88e711be /sys-boot
parentnet-libs/nodejs: Fix build on riscv for version 20.11.0 (diff)
downloadgentoo-46792ce3aca3b580570625dc340631f08aed998c.tar.gz
gentoo-46792ce3aca3b580570625dc340631f08aed998c.tar.bz2
gentoo-46792ce3aca3b580570625dc340631f08aed998c.zip
sys-boot/grub: ignore implicit re_match
Closes: https://bugs.gentoo.org/923736 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-2.06-r9.ebuild2
-rw-r--r--sys-boot/grub/grub-2.12-r1.ebuild2
-rw-r--r--sys-boot/grub/grub-9999.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/sys-boot/grub/grub-2.06-r9.ebuild b/sys-boot/grub/grub-2.06-r9.ebuild
index 1e41a5ab1fc2..adeb7f089446 100644
--- a/sys-boot/grub/grub-2.06-r9.ebuild
+++ b/sys-boot/grub/grub-2.06-r9.ebuild
@@ -313,7 +313,7 @@ src_install() {
if use elibc_musl; then
# https://bugs.gentoo.org/900348
- QA_CONFIG_IMPL_DECL_SKIP=( re_set_syntax re_compile_pattern re_search )
+ QA_CONFIG_IMPL_DECL_SKIP=( re_{compile_pattern,match,search,set_syntax} )
fi
}
diff --git a/sys-boot/grub/grub-2.12-r1.ebuild b/sys-boot/grub/grub-2.12-r1.ebuild
index 036d1f5670fa..4841cdc866db 100644
--- a/sys-boot/grub/grub-2.12-r1.ebuild
+++ b/sys-boot/grub/grub-2.12-r1.ebuild
@@ -317,7 +317,7 @@ src_install() {
if use elibc_musl; then
# https://bugs.gentoo.org/900348
- QA_CONFIG_IMPL_DECL_SKIP=( re_set_syntax re_compile_pattern re_search )
+ QA_CONFIG_IMPL_DECL_SKIP=( re_{compile_pattern,match,search,set_syntax} )
fi
}
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 1a4cfde422a0..0ba8261571a5 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -313,7 +313,7 @@ src_install() {
if use elibc_musl; then
# https://bugs.gentoo.org/900348
- QA_CONFIG_IMPL_DECL_SKIP=( re_set_syntax re_compile_pattern re_search )
+ QA_CONFIG_IMPL_DECL_SKIP=( re_{compile_pattern,match,search,set_syntax} )
fi
}