summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-02-21 10:17:33 -0800
committerPatrick McLean <chutzpah@gentoo.org>2024-02-21 10:17:54 -0800
commitfccc4216e9c0f980c798365f0e459ef4dd8ebcd2 (patch)
tree7acc7b03dd4adcca4bfd95849502599d89f267b3 /sys-apps
parentwww-client/luakit: add 2.3.6 (diff)
downloadgentoo-fccc4216e9c0f980c798365f0e459ef4dd8ebcd2.tar.gz
gentoo-fccc4216e9c0f980c798365f0e459ef4dd8ebcd2.tar.bz2
gentoo-fccc4216e9c0f980c798365f0e459ef4dd8ebcd2.zip
sys-apps/bolt: add 0.9.7
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bolt/Manifest1
-rw-r--r--sys-apps/bolt/bolt-0.9.7.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-apps/bolt/Manifest b/sys-apps/bolt/Manifest
index d5037a9a997c..da10152e37d4 100644
--- a/sys-apps/bolt/Manifest
+++ b/sys-apps/bolt/Manifest
@@ -2,3 +2,4 @@ DIST bolt-0.9.1.tar.gz 250978 BLAKE2B a3b1ea51704e2b54abb0135013019b9cad6ed9c0ac
DIST bolt-0.9.2.tar.gz 252532 BLAKE2B 45ea8ae2e77a90099152e708dafe68e63492d0370b734612b516d4a772507174c3df75ddd7d6bdea4be5022a88e1e286a738d3b8df6a662ef3b0b92ac7328730 SHA512 69e7ffa58a6dbc8a1b14fd7e11e2291fa60227896ead1a449839716b581c6ab0e351d3ed62f9b51c5e44a5a33ba5e23dc5af73a1b4eef87f733b3231d5454e90
DIST bolt-0.9.3.tar.gz 253085 BLAKE2B 7547a35aa16a7681737989c72dfd2e13245eb50c7b814de979974750e3c8805156fd22054308d715299baab3ebd4144923aacc04ef301ee039e84b6370cbcba7 SHA512 2160831011090e75cf54408525f53ead6c0e7797de8a4afdd07ef5a035f8e1aa58f34efb9bd52e6e7cd93ac17751e72ff27e99f2b372a5720b2cbadd6abb3c26
DIST bolt-0.9.6.tar.bz2 192324 BLAKE2B 88e5b94e75833bb5cef090650158ffd26e642188e876cf54407fee7535498faa7ff138b7d47911ea85cacf2bb6ac778b32c23d5cd942c27d1edacc395ec6c9a3 SHA512 7a72b17dbb02917fd55cc480bc4c3ec948577b61aab2ffb366608e82ca65add4e7b402c3b89fd3f98f660165b335ebc9564444bbae3ab55bd6a63c4e0019266a
+DIST bolt-0.9.7.tar.gz 255976 BLAKE2B c7764cb1334f2df96856cb9a92fe6c0ba97ed81340690537fe4567f81bbbf1ee4fbfc659c8b43716f6756d53ab21c71a5c8c9952aea19d1c3f0c14386d327331 SHA512 a9ae0425cdba8932356ec4dcf3f6b3469478c01d47ef3b741c0a841117c81b354f35860be6011ea3b43b28ae10164909a82e2bdbcf92e8541c637cf44277a36c
diff --git a/sys-apps/bolt/bolt-0.9.7.ebuild b/sys-apps/bolt/bolt-0.9.7.ebuild
new file mode 100644
index 000000000000..3fc4a5615f8e
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson udev
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="selinux test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ virtual/libudev:=
+ virtual/udev
+ sys-auth/polkit[introspection]
+ selinux? ( sec-policy/selinux-thunderbolt )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/umockdev )
+"
+BDEPEND="
+ app-text/asciidoc
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use kernel_linux && kernel_is lt 5 6; then
+ CONFIG_CHECK="~THUNDERBOLT"
+ ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
+ else
+ CONFIG_CHECK="~USB4"
+ ERROR_USB4="This package requires the USB4 kernel driver for Thunderbolt support."
+ fi
+ CONFIG_CHECK+=" ~HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
+
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman=true
+ --sysconfdir="${EPREFIX}"/etc
+ --localstatedir="${EPREFIX}"/var
+ --sharedstatedir="${EPREFIX}"/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.openrc-r1 boltd
+ keepdir /var/lib/boltd
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}