summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-09-06 14:44:37 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-09-06 15:21:29 +0300
commit8683efc535c2c0396fc4b4625341fce79de91667 (patch)
tree73dfbbaf8cb37bc4e4872c66b40263ee85880b22 /sys-apps
parentdev-scheme/slib: fix syntax issue (diff)
downloadgentoo-8683efc535c2c0396fc4b4625341fce79de91667.tar.gz
gentoo-8683efc535c2c0396fc4b4625341fce79de91667.tar.bz2
gentoo-8683efc535c2c0396fc4b4625341fce79de91667.zip
sys-apps/pkgcore: add 0.12.28
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.28.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index f00e95f74c6d..a210297bce59 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -1 +1,2 @@
DIST pkgcore-0.12.27.tar.gz 636436 BLAKE2B a03b795eb685b552659b6110a9a19e6915320f3bcc87a4c5343a9ae16b82ebea46b538d8606ff10fa1f1c46f85117aeec240247e98aaccc00b0c67996bd2421a SHA512 99e8e125fbb086a98f6c2f494624e63d47d2f594f952eb5e540eba355161eecaeb55ffc3f2df951cdfcd9cb5b1720411c58e2ab4f3299a63eeafa44eed6f7912
+DIST pkgcore-0.12.28.tar.gz 636701 BLAKE2B 5bb80f42b7de8ca39ee7379fae6ea3a1e2a3fec5f799f72a8a0425a4185c85968756778daf244d048ef7028bb8a71e45d6bd913843c5eb3a218a5daa78d198a6 SHA512 0e3c8c174826acc41edc4625fd4c2ae0759d5de015768110d06fac87be9ac2f1f4feefc48880735834474ec89b96e3c245d0619ea6986ec0c7323a9dc106f40e
diff --git a/sys-apps/pkgcore/pkgcore-0.12.28.ebuild b/sys-apps/pkgcore/pkgcore-0.12.28.ebuild
new file mode 100644
index 000000000000..1dc106e93939
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.28.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgcore.git
+ https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ inherit pypi
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ COMMON_DEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ COMMON_DEPEND=">=dev-python/snakeoil-0.10.7[${PYTHON_USEDEP}]"
+fi
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ >=app-shells/bash-5.1[readline]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${COMMON_DEPEND}
+ >=dev-python/flit-core-3.8[${PYTHON_USEDEP}]
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman build/sphinx/man/*
+ distutils-r1_python_install_all
+}