summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-02-13 15:43:41 +0000
committerMatt Turner <mattst88@gentoo.org>2021-03-24 12:07:00 -0400
commit1d1ebd8a342cedd4a65cbce1da09113254df2ab0 (patch)
treec2a97f56ed9666cff01da28891675321f9c51258 /sys-apps
parentsys-apps/fwupd: revbump for d-m-i (diff)
downloadgentoo-1d1ebd8a342cedd4a65cbce1da09113254df2ab0.tar.gz
gentoo-1d1ebd8a342cedd4a65cbce1da09113254df2ab0.tar.bz2
gentoo-1d1ebd8a342cedd4a65cbce1da09113254df2ab0.zip
sys-apps/bolt: revbump for d-m-i
Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bolt/bolt-0.9-r3.ebuild57
-rw-r--r--sys-apps/bolt/files/bolt.openrc-r114
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/bolt/bolt-0.9-r3.ebuild b/sys-apps/bolt/bolt-0.9-r3.ebuild
new file mode 100644
index 000000000000..34cd766665ec
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ dev-util/glib-utils
+ virtual/libudev
+ virtual/udev
+ dev-util/umockdev
+ sys-auth/polkit[introspection]
+ systemd? ( sys-apps/systemd )
+ doc? ( app-text/asciidoc )"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ if use kernel_linux && kernel_is lt 5 6; then
+ CONFIG_CHECK="~THUNDERBOLT"
+ ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
+ else
+ CONFIG_CHECK="~USB4"
+ ERROR_USB4="This package requires the USB4 kernel driver for Thunderbolt support."
+ fi
+ check_extra_config
+
+ CONFIG_CHECK="~HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
+ check_extra_config
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman=$(usex doc true false)
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --sharedstatedir=/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.openrc-r1 boltd
+ keepdir /var/lib/boltd
+}
diff --git a/sys-apps/bolt/files/bolt.openrc-r1 b/sys-apps/bolt/files/bolt.openrc-r1
new file mode 100644
index 000000000000..f47b15ffaecb
--- /dev/null
+++ b/sys-apps/bolt/files/bolt.openrc-r1
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="Thunderbolt Security Daemon"
+description="Userspace system daemon to enable security levels for Thunderbolt 3"
+command="/usr/libexec/boltd"
+command_background="true"
+pidfile="/var/run/boltd.pid"
+
+depend() {
+ need dbus
+ before display-manager
+}