summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-24 12:00:29 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-24 12:43:47 -0400
commit1cb7eb5c4059f53aad88fb1e826f496a3c37d5d2 (patch)
tree87ff8cad60fdc17d24179a4b9ef18767cbd5b347 /sys-apps/xdg-desktop-portal-gnome
parentsys-apps/xdg-desktop-portal: Version bump to 1.15.0 (diff)
downloadgentoo-1cb7eb5c4059f53aad88fb1e826f496a3c37d5d2.tar.gz
gentoo-1cb7eb5c4059f53aad88fb1e826f496a3c37d5d2.tar.bz2
gentoo-1cb7eb5c4059f53aad88fb1e826f496a3c37d5d2.zip
sys-apps/xdg-desktop-portal-gnome: Version bump to 43.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gnome')
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-43.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/Manifest b/sys-apps/xdg-desktop-portal-gnome/Manifest
index 7970daea9ad6..6e6f4ae1636d 100644
--- a/sys-apps/xdg-desktop-portal-gnome/Manifest
+++ b/sys-apps/xdg-desktop-portal-gnome/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-gnome-42.3.tar.xz 119228 BLAKE2B 1cafeda9e9ad5431eb52520db19350e9ee4c9f65e0923f6f320561893a29e32fc5033f3da540dd492c3341a8cb6bf29687cbf04b027e68ee388d102ac7023cac SHA512 0704eb29af5464fa0598cb4a05451866c8bacc20ad0638f7e799e7abdb4bbd86c41efbad963c493767190ae55f9d9c5d28360ee5fbbe1c42881969d03c7e84f5
+DIST xdg-desktop-portal-gnome-43.0.tar.xz 123836 BLAKE2B 304655c999cf938de6cff23e190835d3a902dce81e64b041dfd2ceed817ec239cb67479dc3fca979659dc15d31acb12e36f38499408c6a063e412760f28266ac SHA512 57dc455b19fc0c22aac9fb9fab375964999e99d96d2c6452ffecde3081e3a5a860eaf04dbada5ed87d43ae35119d1ab4d4fdfce3d1a9dc54b20862166984c2b3
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-43.0.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-43.0.ebuild
new file mode 100644
index 000000000000..a29af51cf559
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-43.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ gui-libs/libadwaita:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.15.0
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}