summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-11-10 12:18:06 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-11-10 12:18:45 +0100
commitea6d8e135b8ed985d40bad74d33a9368686465a6 (patch)
tree9465949e9ef523249fbead991e419e49d07ec7e7 /sys-apps/sysvinit
parentnet-print/gutenprint: Fix ROOT detection and canon/epson bugs (diff)
downloadgentoo-ea6d8e135b8ed985d40bad74d33a9368686465a6.tar.gz
gentoo-ea6d8e135b8ed985d40bad74d33a9368686465a6.tar.bz2
gentoo-ea6d8e135b8ed985d40bad74d33a9368686465a6.zip
sys-apps/sysvinit: Fixed ${ROOT} check for EAPI-7
Closes: https://bugs.gentoo.org/753824 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/sysvinit')
-rw-r--r--sys-apps/sysvinit/sysvinit-2.96.ebuild2
-rw-r--r--sys-apps/sysvinit/sysvinit-2.97.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-apps/sysvinit/sysvinit-2.96.ebuild b/sys-apps/sysvinit/sysvinit-2.96.ebuild
index adf3f15ec1e7..b82c9e06198e 100644
--- a/sys-apps/sysvinit/sysvinit-2.96.ebuild
+++ b/sys-apps/sysvinit/sysvinit-2.96.ebuild
@@ -121,7 +121,7 @@ pkg_postinst() {
# Reload init to fix unmounting problems of / on next reboot.
# This is really needed, as without the new version of init cause init
# not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [[ ${ROOT} == / ]] ; then
+ if [[ -z ${ROOT} ]] ; then
if [[ -e /dev/initctl && ! -e /run/initctl ]]; then
ln -s /dev/initctl /run/initctl
fi
diff --git a/sys-apps/sysvinit/sysvinit-2.97.ebuild b/sys-apps/sysvinit/sysvinit-2.97.ebuild
index 4dd4d992de92..218791b88a28 100644
--- a/sys-apps/sysvinit/sysvinit-2.97.ebuild
+++ b/sys-apps/sysvinit/sysvinit-2.97.ebuild
@@ -125,7 +125,7 @@ pkg_postinst() {
# Reload init to fix unmounting problems of / on next reboot.
# This is really needed, as without the new version of init cause init
# not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [[ ${ROOT} == / ]] ; then
+ if [[ -z ${ROOT} ]] ; then
if [[ -e /dev/initctl ]] && [[ ! -e /run/initctl ]] ; then
ln -s /dev/initctl /run/initctl \
|| ewarn "Failed to set /run/initctl symlink!"