summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2020-12-17 18:58:32 -0800
committerJason Zaman <perfinion@gentoo.org>2020-12-17 19:00:20 -0800
commit3d7f7b36d3c4ab7f77c93cf1db998e2ef00afebe (patch)
treed437707a89a31adfe2bd99a13a698f47fef227ea /sys-apps/selinux-python
parentsys-apps/policycoreutils: Drop old (diff)
downloadgentoo-3d7f7b36d3c4ab7f77c93cf1db998e2ef00afebe.tar.gz
gentoo-3d7f7b36d3c4ab7f77c93cf1db998e2ef00afebe.tar.bz2
gentoo-3d7f7b36d3c4ab7f77c93cf1db998e2ef00afebe.zip
sys-apps/selinux-python: Drop old
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/selinux-python')
-rw-r--r--sys-apps/selinux-python/Manifest2
-rw-r--r--sys-apps/selinux-python/selinux-python-2.9.ebuild95
-rw-r--r--sys-apps/selinux-python/selinux-python-3.0.ebuild95
-rw-r--r--sys-apps/selinux-python/selinux-python-3.1.ebuild94
4 files changed, 0 insertions, 286 deletions
diff --git a/sys-apps/selinux-python/Manifest b/sys-apps/selinux-python/Manifest
index 95ab19c41761..b5467d1670ab 100644
--- a/sys-apps/selinux-python/Manifest
+++ b/sys-apps/selinux-python/Manifest
@@ -1,3 +1 @@
-DIST selinux-python-2.9.tar.gz 2100185 BLAKE2B 8aad58264197dbf23dfa286ba6530150ca6ae1ddaeb1a58988c05d0b122420cfd7e9be2a1cb7082d73cd41f03c4df00ad81a0fb746b075db24e63f62f86a1bf1 SHA512 1138661128635004fec04dc5e39f035680b5f21beb1b79f3328690a1b93a3984d522a02724af793340112a5e647d363dda8a7d3536de959b34ffd69aa396254d
-DIST selinux-python-3.0.tar.gz 2100098 BLAKE2B 6949911020139378e9bdcc2b7c01c067ddaf71394a0a143a096d5708c5e7caa468b12826965c02af0b994f35d26c573187bf67c8d1ce75f5e8a31a1fb0fc6562 SHA512 743df60a643477465e4355880c56813ea8539415ea7c9631fb9b7cd7969a37cce572a6a94b785065d92baf9d7b6c753daa5d2f9709df7c9203c7effba46d58f2
DIST selinux-python-3.1.tar.gz 2100549 BLAKE2B c5d207bad60c379259e3bfc8f029f76d4572818cdd41a263498ed4434a70eaf7ff51af7772cfb27de0e9e4af03bcf9906ab0f6a59e88de10e81cbe0e8c5928b8 SHA512 5dd98f77ae8ea8bac6a89ec7def76e12496b9a9f8c9612c4cc1dac7a8e8c60380a00c857426bfefbcb4273706addd2594e9b467f69408ef284f082a09d45bd49
diff --git a/sys-apps/selinux-python/selinux-python-2.9.ebuild b/sys-apps/selinux-python/selinux-python-2.9.ebuild
deleted file mode 100644
index 411c26e363e7..000000000000
--- a/sys-apps/selinux-python/selinux-python-2.9.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="xml"
-
-inherit python-r1 toolchain-funcs
-
-MY_P="${P//_/-}"
-
-MY_RELEASEDATE="20190315"
-SEPOL_VER="${PV}"
-SELNX_VER="${PV}"
-SEMNG_VER="${PV}"
-
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN#selinux-}"
-else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~mips x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
- >=sys-libs/libsemanage-${SEMNG_VER}:=[python(+)]
- >=sys-libs/libsepol-${SEPOL_VER}:=
- >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
- dev-python/ipy[${PYTHON_USEDEP}]
- !dev-python/sepolgen
- ${PYTHON_DEPS}"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
-
- python_copy_sources
-}
-
-src_compile() {
- building() {
- emake -C "${BUILD_DIR}" \
- CC="$(tc-getCC)" \
- LIBDIR="\$(PREFIX)/$(get_libdir)"
- }
- python_foreach_impl building
-}
-
-src_install() {
- installation() {
- emake -C "${BUILD_DIR}" \
- DESTDIR="${D}" \
- LIBDIR="\$(PREFIX)/$(get_libdir)" \
- install
- python_optimize
- }
- python_foreach_impl installation
-
- # Set version-specific scripts
- for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
- done
- for pyscript in semanage; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
- done
-
- # Create sepolgen.conf with different devel location definition
- if [[ -f /etc/selinux/config ]];
- then
- local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
- mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- local selinuxtype="${POLICY_TYPES%% *}";
- if [[ -n "${selinuxtype}" ]];
- then
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
- fi
- fi
-}
diff --git a/sys-apps/selinux-python/selinux-python-3.0.ebuild b/sys-apps/selinux-python/selinux-python-3.0.ebuild
deleted file mode 100644
index 96deaf538c58..000000000000
--- a/sys-apps/selinux-python/selinux-python-3.0.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python{3_6,3_7} )
-PYTHON_REQ_USE="xml"
-
-inherit python-r1 toolchain-funcs
-
-MY_P="${P//_/-}"
-
-MY_RELEASEDATE="20191204"
-SEPOL_VER="${PV}"
-SELNX_VER="${PV}"
-SEMNG_VER="${PV}"
-
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN#selinux-}"
-else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~mips x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
- >=sys-libs/libsemanage-${SEMNG_VER}:=[python(+)]
- >=sys-libs/libsepol-${SEPOL_VER}:=
- >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
- dev-python/ipy[${PYTHON_USEDEP}]
- !dev-python/sepolgen
- ${PYTHON_DEPS}"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
-
- python_copy_sources
-}
-
-src_compile() {
- building() {
- emake -C "${BUILD_DIR}" \
- CC="$(tc-getCC)" \
- LIBDIR="\$(PREFIX)/$(get_libdir)"
- }
- python_foreach_impl building
-}
-
-src_install() {
- installation() {
- emake -C "${BUILD_DIR}" \
- DESTDIR="${D}" \
- LIBDIR="\$(PREFIX)/$(get_libdir)" \
- install
- python_optimize
- }
- python_foreach_impl installation
-
- # Set version-specific scripts
- for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
- done
- for pyscript in semanage; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
- done
-
- # Create sepolgen.conf with different devel location definition
- if [[ -f /etc/selinux/config ]];
- then
- local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
- mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- local selinuxtype="${POLICY_TYPES%% *}";
- if [[ -n "${selinuxtype}" ]];
- then
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
- fi
- fi
-}
diff --git a/sys-apps/selinux-python/selinux-python-3.1.ebuild b/sys-apps/selinux-python/selinux-python-3.1.ebuild
deleted file mode 100644
index d890afd5e440..000000000000
--- a/sys-apps/selinux-python/selinux-python-3.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-PYTHON_REQ_USE="xml"
-
-inherit python-r1 toolchain-funcs
-
-MY_P="${P//_/-}"
-
-MY_RELEASEDATE="20200710"
-SEPOL_VER="${PV}"
-SELNX_VER="${PV}"
-SEMNG_VER="${PV}"
-
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN#selinux-}"
-else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~mips ~x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
- >=sys-libs/libsemanage-${SEMNG_VER}:=[python(+)]
- >=sys-libs/libsepol-${SEPOL_VER}:=
- >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
- dev-python/ipy[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
-
- python_copy_sources
-}
-
-src_compile() {
- building() {
- emake -C "${BUILD_DIR}" \
- CC="$(tc-getCC)" \
- LIBDIR="\$(PREFIX)/$(get_libdir)"
- }
- python_foreach_impl building
-}
-
-src_install() {
- installation() {
- emake -C "${BUILD_DIR}" \
- DESTDIR="${D}" \
- LIBDIR="\$(PREFIX)/$(get_libdir)" \
- install
- python_optimize
- }
- python_foreach_impl installation
-
- # Set version-specific scripts
- for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
- done
- for pyscript in semanage; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
- done
-
- # Create sepolgen.conf with different devel location definition
- if [[ -f /etc/selinux/config ]];
- then
- local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
- mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- local selinuxtype="${POLICY_TYPES%% *}";
- if [[ -n "${selinuxtype}" ]];
- then
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
- fi
- fi
-}