summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-09 01:58:57 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-09 02:38:30 +0800
commit314270307d9a4c640d63ce0ea2d039cfc94a6953 (patch)
treed22f404f5a995a09c48e650279a6959640dfc2f5 /sys-apps/selinux-python
parentsys-apps/policycoreutils: drop old (diff)
downloadgentoo-314270307d9a4c640d63ce0ea2d039cfc94a6953.tar.gz
gentoo-314270307d9a4c640d63ce0ea2d039cfc94a6953.tar.bz2
gentoo-314270307d9a4c640d63ce0ea2d039cfc94a6953.zip
sys-apps/selinux-python: drop old
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/selinux-python')
-rw-r--r--sys-apps/selinux-python/Manifest2
-rw-r--r--sys-apps/selinux-python/selinux-python-2.8-r1.ebuild95
-rw-r--r--sys-apps/selinux-python/selinux-python-3.0_rc2.ebuild95
3 files changed, 0 insertions, 192 deletions
diff --git a/sys-apps/selinux-python/Manifest b/sys-apps/selinux-python/Manifest
index 24295005e02b..b7c1dcd32c67 100644
--- a/sys-apps/selinux-python/Manifest
+++ b/sys-apps/selinux-python/Manifest
@@ -1,4 +1,2 @@
-DIST selinux-python-2.8.tar.gz 2068101 BLAKE2B c28f12e4bd453955148a6ba82fd28621d1a4600f872ac63d97372f2e0153091adf1cf871f89765dd300bc6b7b2d610b96f87e3fc5accbfad713ed8a0d8f76f5a SHA512 e695c11122f7f8105b75d1ef98355fd2b82b40d93c2fd9e733dcd95d4d7c392f60b646df81203c43ad2a0e8447f9901083007e1572b78e17368ad2764ffa1aad
DIST selinux-python-2.9.tar.gz 2100185 BLAKE2B 8aad58264197dbf23dfa286ba6530150ca6ae1ddaeb1a58988c05d0b122420cfd7e9be2a1cb7082d73cd41f03c4df00ad81a0fb746b075db24e63f62f86a1bf1 SHA512 1138661128635004fec04dc5e39f035680b5f21beb1b79f3328690a1b93a3984d522a02724af793340112a5e647d363dda8a7d3536de959b34ffd69aa396254d
-DIST selinux-python-3.0-rc2.tar.gz 2100248 BLAKE2B de70c03b3cb3eb1fc977a9789ed24de82b472a7f520bcb038f3ab0862407f6dadd3a584b07c136e24b1296df0b48e3ec8818ba2c4ed3261dd2c134f3bba8654f SHA512 ab02fc11678a1d44294d24ed0fe1e00edb75a775a2ef1b61575016afac7c8bd024a41292c934437a2fee17fbf6f78b32ef9a5907d90d5ec9fc5e295522a4bc08
DIST selinux-python-3.0.tar.gz 2100098 BLAKE2B 6949911020139378e9bdcc2b7c01c067ddaf71394a0a143a096d5708c5e7caa468b12826965c02af0b994f35d26c573187bf67c8d1ce75f5e8a31a1fb0fc6562 SHA512 743df60a643477465e4355880c56813ea8539415ea7c9631fb9b7cd7969a37cce572a6a94b785065d92baf9d7b6c753daa5d2f9709df7c9203c7effba46d58f2
diff --git a/sys-apps/selinux-python/selinux-python-2.8-r1.ebuild b/sys-apps/selinux-python/selinux-python-2.8-r1.ebuild
deleted file mode 100644
index 76d7035f05ae..000000000000
--- a/sys-apps/selinux-python/selinux-python-2.8-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python{3_5,3_6} )
-PYTHON_REQ_USE="xml"
-
-inherit python-r1 toolchain-funcs
-
-MY_P="${P//_/-}"
-
-MY_RELEASEDATE="20180524"
-SEPOL_VER="${PV}"
-SELNX_VER="${PV}"
-SEMNG_VER="${PV}"
-
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN#selinux-}"
-else
- SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~mips x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
- >=sys-libs/libsemanage-${SEMNG_VER}:=[python]
- >=sys-libs/libsepol-${SEPOL_VER}:=
- >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
- dev-python/ipy[${PYTHON_USEDEP}]
- !dev-python/sepolgen
- ${PYTHON_DEPS}"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
-
- python_copy_sources
-}
-
-src_compile() {
- building() {
- emake -C "${BUILD_DIR}" \
- CC="$(tc-getCC)" \
- LIBDIR="\$(PREFIX)/$(get_libdir)"
- }
- python_foreach_impl building
-}
-
-src_install() {
- installation() {
- emake -C "${BUILD_DIR}" \
- DESTDIR="${D}" \
- LIBDIR="\$(PREFIX)/$(get_libdir)" \
- install
- python_optimize
- }
- python_foreach_impl installation
-
- # Set version-specific scripts
- for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
- done
- for pyscript in semanage; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
- done
-
- # Create sepolgen.conf with different devel location definition
- if [[ -f /etc/selinux/config ]];
- then
- local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
- mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- local selinuxtype="${POLICY_TYPES%% *}";
- if [[ -n "${selinuxtype}" ]];
- then
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
- fi
- fi
-}
diff --git a/sys-apps/selinux-python/selinux-python-3.0_rc2.ebuild b/sys-apps/selinux-python/selinux-python-3.0_rc2.ebuild
deleted file mode 100644
index 7d2a3ff54832..000000000000
--- a/sys-apps/selinux-python/selinux-python-3.0_rc2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python{3_5,3_6,3_7} )
-PYTHON_REQ_USE="xml"
-
-inherit python-r1 toolchain-funcs
-
-MY_P="${P//_/-}"
-
-MY_RELEASEDATE="20191122"
-SEPOL_VER="${PV}"
-SELNX_VER="${PV}"
-SEMNG_VER="${PV}"
-
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN#selinux-}"
-else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~mips ~x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
- >=sys-libs/libsemanage-${SEMNG_VER}:=[python]
- >=sys-libs/libsepol-${SEPOL_VER}:=
- >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
- dev-python/ipy[${PYTHON_USEDEP}]
- !dev-python/sepolgen
- ${PYTHON_DEPS}"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
-
- python_copy_sources
-}
-
-src_compile() {
- building() {
- emake -C "${BUILD_DIR}" \
- CC="$(tc-getCC)" \
- LIBDIR="\$(PREFIX)/$(get_libdir)"
- }
- python_foreach_impl building
-}
-
-src_install() {
- installation() {
- emake -C "${BUILD_DIR}" \
- DESTDIR="${D}" \
- LIBDIR="\$(PREFIX)/$(get_libdir)" \
- install
- python_optimize
- }
- python_foreach_impl installation
-
- # Set version-specific scripts
- for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
- done
- for pyscript in semanage; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
- done
-
- # Create sepolgen.conf with different devel location definition
- if [[ -f /etc/selinux/config ]];
- then
- local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
- mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- local selinuxtype="${POLICY_TYPES%% *}";
- if [[ -n "${selinuxtype}" ]];
- then
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
- fi
- fi
-}