summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-05-18 09:25:17 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-18 12:37:48 +0200
commitf908799e1426c93655cbbab52652ae8ca28e7b89 (patch)
tree4496c2273f3ac756a24f3d04c6350a43e70de509 /sys-apps/plocate
parentsys-kernel/gentoo-sources: add 5.17.9 (diff)
downloadgentoo-f908799e1426c93655cbbab52652ae8ca28e7b89.tar.gz
gentoo-f908799e1426c93655cbbab52652ae8ca28e7b89.tar.bz2
gentoo-f908799e1426c93655cbbab52652ae8ca28e7b89.zip
sys-apps/plocate: only check for io-uring kernel config if USE enabled
Closes: https://bugs.gentoo.org/844883 Closes: https://github.com/gentoo/gentoo/pull/25546 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-apps/plocate')
-rw-r--r--sys-apps/plocate/plocate-1.1.15.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-apps/plocate/plocate-1.1.15.ebuild b/sys-apps/plocate/plocate-1.1.15.ebuild
index 3fb8c7c34d07..5df0276d30a1 100644
--- a/sys-apps/plocate/plocate-1.1.15.ebuild
+++ b/sys-apps/plocate/plocate-1.1.15.ebuild
@@ -24,13 +24,18 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-CONFIG_CHECK="~IO_URING"
-ERROR_IO_URING="required for USE=io-uring"
-
PATCHES=(
"${FILESDIR}"/${PN}-1.1.15-meson-use-feature-option-for-libiouring.patch
)
+pkg_setup() {
+ if use io-uring && linux_config_exists; then
+ if ! linux_chkconfig_present IO_URING; then
+ ewarn "CONFIG_IO_URING must be enabled for USE=io-uring"
+ fi
+ fi
+}
+
src_prepare() {
# We'll install the manpage ourself to locate.1
sed -i "/install_man('plocate.1')/d" meson.build || die