summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/makedev/makedev-3.23.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/makedev/makedev-3.23.1.ebuild')
-rw-r--r--sys-apps/makedev/makedev-3.23.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/makedev/makedev-3.23.1.ebuild b/sys-apps/makedev/makedev-3.23.1.ebuild
new file mode 100644
index 000000000000..6cc925cf58af
--- /dev/null
+++ b/sys-apps/makedev/makedev-3.23.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_PN="MAKEDEV"
+MY_VER=${PV%.*}
+MY_REL=${PV#${MY_VER}.}
+MY_P="${MY_PN}-${MY_VER}"
+DESCRIPTION="program used for creating device files in /dev"
+HOMEPAGE="http://people.redhat.com/nalin/MAKEDEV/"
+SRC_URI="http://people.redhat.com/nalin/MAKEDEV/${MY_P}-${MY_REL}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="build selinux"
+
+RDEPEND="!<sys-apps/baselayout-2.0.0_rc"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-headers.patch #339674
+}
+
+src_compile() {
+ use selinux && export SELINUX=1
+ emake CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ # set devdir to makedevdir so we dont have to worry about /dev
+ emake install DESTDIR="${D}" makedevdir=/sbin devdir=/sbin || die
+ dodoc *.txt
+ keepdir /dev
+}
+
+pkg_postinst() {
+ if use build ; then
+ # set up a base set of nodes to make recovery easier #368597
+ "${ROOT}"/sbin/MAKEDEV -c "${ROOT}"/etc/makedev.d \
+ -d "${ROOT}"/dev console hda input ptmx std sd tty
+ # trim useless nodes
+ rm -f "${ROOT}"/dev/fd[0-9]* # floppy
+ rm -f "${ROOT}"/dev/sd[a-d][a-z]* "${ROOT}"/dev/sd[e-z]* # excess sata/scsi
+ rm -f "${ROOT}"/dev/tty[a-zA-Z]* # excess tty
+ fi
+}