summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-09 03:50:35 +0000
committerSam James <sam@gentoo.org>2023-02-09 03:54:10 +0000
commit21bc40938e72c900e6257832eb05039cc9d8c9c6 (patch)
tree4b2d62f0a9c1381cc406341f3e3ca6ad2bc42624 /sys-apps/less
parentsys-apps/less: patch CVE-2022-46663 (diff)
downloadgentoo-21bc40938e72c900e6257832eb05039cc9d8c9c6.tar.gz
gentoo-21bc40938e72c900e6257832eb05039cc9d8c9c6.tar.bz2
gentoo-21bc40938e72c900e6257832eb05039cc9d8c9c6.zip
sys-apps/less: add 623_beta (unkeyworded)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/less')
-rw-r--r--sys-apps/less/Manifest1
-rw-r--r--sys-apps/less/less-623_beta.ebuild77
-rw-r--r--sys-apps/less/less-9999.ebuild14
3 files changed, 89 insertions, 3 deletions
diff --git a/sys-apps/less/Manifest b/sys-apps/less/Manifest
index 8b826e5261fa..46a99b17fbb3 100644
--- a/sys-apps/less/Manifest
+++ b/sys-apps/less/Manifest
@@ -1,2 +1,3 @@
DIST less-608.tar.gz 362346 BLAKE2B 988940745fef1222c43b0bf4edec7cc7206ded0ac5d89d3faf4dab706a249913581c2fe7aa6063cf3d717176ed07b69299d3e791ba8a60358483fe9d1bf7f7c6 SHA512 7945b7f88921832ebb1b45fba8cbb449ee0133342796b654a52c146dfff3d84db18724ee84e53349eeea6017a0ebe2d8eb5366210275981dde7bb7190118fa66
DIST less-618-beta.tar.gz 365786 BLAKE2B b1957ab49059a2df14d8ba5daf1d8543adc4546c44b537d86959e2e1fe2df93f99ceb8ef47097b6f84f75f7740e161269b4e1d5dd263b8171212c87e650a02fe SHA512 6197aa20c77a846e53b376aa63c2863242c40663e72213f66c3597bd8c38a9458163d0c9ba0ca7690574c07348bb7d3e108c3b50dbbedbc9e5707a14d946b280
+DIST less-623-beta.tar.gz 373094 BLAKE2B 661fdb129678a57ef2188b4cd89809b14eaae62b98bb8ec2394cb7b48faf10a3ccdb690f371178e9ed43548ebce1af840cb5042e9019fa747bcec2dca4158dc7 SHA512 60843c668f90ae47cdf4d10849a63481ab67af679b831cbe8955861ae9f238006322734ec3ae49d9aced7927018bf3e0d9fdab98077289b4ffc78f6075041667
diff --git a/sys-apps/less/less-623_beta.ebuild b/sys-apps/less/less-623_beta.ebuild
new file mode 100644
index 000000000000..84957e8eccd9
--- /dev/null
+++ b/sys-apps/less/less-623_beta.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WANT_AUTOMAKE=none
+WANT_LIBTOOL=none
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/gwsw/less"
+ inherit git-r3
+fi
+
+inherit autotools
+
+# Releases are usually first a beta then promoted to stable if no
+# issues were found. Upstream explicitly ask "to not generally distribute"
+# the beta versions. It's okay to keyword beta versions if they fix
+# a serious bug, but otherwise try to avoid it.
+
+MY_PV=${PV/_beta/-beta}
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+[[ ${PV} != 9999 ]] && SRC_URI="http://www.greenwoodsoftware.com/less/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P/?beta}
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre"
+# As of 623_beta, lesstest is not included in dist tarballs
+RESTRICT="test"
+
+DEPEND="
+ >=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2:=
+ pcre? ( dev-libs/libpcre2 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ # Per upstream README to prepare live build
+ [[ ${PV} == 9999 ]] && emake -f Makefile.aut distfiles
+ # Upstream uses unpatched autoconf-2.69, which breaks with clang-16.
+ # https://bugs.gentoo.org/870412
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-regex=$(usex pcre pcre2 posix)
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake check VERBOSE=1
+}
+
+src_install() {
+ default
+
+ newbin "${FILESDIR}"/lesspipe-r1.sh lesspipe
+ newenvd "${FILESDIR}"/less.envd 70less
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-483-r1" ; then
+ elog "The lesspipe.sh symlink has been dropped. If you are still setting"
+ elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
+ elog "Colorization support has been dropped. If you want that, check out"
+ elog "the new app-text/lesspipe package."
+ fi
+}
diff --git a/sys-apps/less/less-9999.ebuild b/sys-apps/less/less-9999.ebuild
index afce93c3d215..84957e8eccd9 100644
--- a/sys-apps/less/less-9999.ebuild
+++ b/sys-apps/less/less-9999.ebuild
@@ -29,10 +29,14 @@ LICENSE="|| ( GPL-3 BSD-2 )"
SLOT="0"
#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="pcre"
+# As of 623_beta, lesstest is not included in dist tarballs
+RESTRICT="test"
-DEPEND=">=app-misc/editor-wrapper-3
- >=sys-libs/ncurses-5.2:0=
- pcre? ( dev-libs/libpcre2 )"
+DEPEND="
+ >=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2:=
+ pcre? ( dev-libs/libpcre2 )
+"
RDEPEND="${DEPEND}"
src_prepare() {
@@ -52,6 +56,10 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_test() {
+ emake check VERBOSE=1
+}
+
src_install() {
default