summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-20 07:55:27 +0100
committerSam James <sam@gentoo.org>2023-05-20 07:56:00 +0100
commit1c98c520d1b838aa3da816eb855edc5de8cc62c6 (patch)
tree5d1b76f14890837a1b6c6808f19d5e96c634433e /sys-apps/flatpak
parentnet-dns/bind-tools: add 9.16.41 (diff)
downloadgentoo-1c98c520d1b838aa3da816eb855edc5de8cc62c6.tar.gz
gentoo-1c98c520d1b838aa3da816eb855edc5de8cc62c6.tar.bz2
gentoo-1c98c520d1b838aa3da816eb855edc5de8cc62c6.zip
sys-apps/flatpak: fix finding fuse(3) slotted binaries
Upstream *do* support fuse3 but they assume the binaries are e.g. 'fusermount', not 'fusermount3' like they are in Gentoo. Closes: https://bugs.gentoo.org/906653 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/flatpak')
-rw-r--r--sys-apps/flatpak/files/flatpak-1.14.4-fuse-3-slotted.patch57
-rw-r--r--sys-apps/flatpak/flatpak-1.14.4-r3.ebuild (renamed from sys-apps/flatpak/flatpak-1.14.4-r2.ebuild)5
2 files changed, 61 insertions, 1 deletions
diff --git a/sys-apps/flatpak/files/flatpak-1.14.4-fuse-3-slotted.patch b/sys-apps/flatpak/files/flatpak-1.14.4-fuse-3-slotted.patch
new file mode 100644
index 000000000000..a0db209fae2f
--- /dev/null
+++ b/sys-apps/flatpak/files/flatpak-1.14.4-fuse-3-slotted.patch
@@ -0,0 +1,57 @@
+https://bugs.gentoo.org/906653
+--- a/common/flatpak-dir.c
++++ b/common/flatpak-dir.c
+@@ -2109,7 +2109,7 @@ flatpak_dir_revokefs_fuse_unmount (OstreeRepo **repo,
+
+ fusermount = g_subprocess_new (G_SUBPROCESS_FLAGS_NONE,
+ error,
+- "fusermount", "-u", "-z", mnt_dir,
++ "fusermount3", "-u", "-z", mnt_dir,
+ NULL);
+ if (g_subprocess_wait_check (fusermount, NULL, error))
+ {
+--- a/tests/can-use-fuse.c
++++ b/tests/can-use-fuse.c
+@@ -53,11 +53,11 @@ check_fuse (void)
+ return FALSE;
+ }
+
+- fusermount = g_find_program_in_path ("fusermount");
++ fusermount = g_find_program_in_path ("fusermount3");
+
+ if (fusermount == NULL)
+ {
+- cannot_use_fuse = g_strdup ("fusermount not found in PATH");
++ cannot_use_fuse = g_strdup ("fusermount3 not found in PATH");
+ return FALSE;
+ }
+
+@@ -69,7 +69,7 @@ check_fuse (void)
+
+ if (!g_file_test ("/etc/mtab", G_FILE_TEST_EXISTS))
+ {
+- cannot_use_fuse = g_strdup ("fusermount won't work without /etc/mtab");
++ cannot_use_fuse = g_strdup ("fusermount3 won't work without /etc/mtab");
+ return FALSE;
+ }
+
+--- a/tests/libtest.sh
++++ b/tests/libtest.sh
+@@ -542,7 +542,7 @@ skip_one_without_bwrap () {
+ }
+
+ skip_without_fuse () {
+- fusermount --version >/dev/null 2>&1 || skip "no fusermount"
++ fusermount3 --version >/dev/null 2>&1 || skip "no fusermount3"
+
+ capsh --print | grep -q 'Bounding set.*[^a-z]cap_sys_admin' || \
+ skip "No cap_sys_admin in bounding set, can't use FUSE"
+@@ -608,7 +608,7 @@ commit_to_path () {
+ cleanup () {
+ /bin/kill -9 $DBUS_SESSION_BUS_PID
+ gpg-connect-agent --homedir "${FL_GPG_HOMEDIR}" killagent /bye >&2 || true
+- fusermount -u $XDG_RUNTIME_DIR/doc >&2 || :
++ fusermount3 -u $XDG_RUNTIME_DIR/doc >&2 || :
+ kill $(jobs -p) &> /dev/null || true
+ if test -n "${TEST_SKIP_CLEANUP:-}"; then
+ echo "# Skipping cleanup of ${TEST_DATA_DIR}"
diff --git a/sys-apps/flatpak/flatpak-1.14.4-r2.ebuild b/sys-apps/flatpak/flatpak-1.14.4-r3.ebuild
index 8b4eb2299d25..1c0aa32c3193 100644
--- a/sys-apps/flatpak/flatpak-1.14.4-r2.ebuild
+++ b/sys-apps/flatpak/flatpak-1.14.4-r3.ebuild
@@ -48,7 +48,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-# pyparsing version pinned for https://bugs.gentoo.org/825230
BDEPEND="
>=sys-devel/automake-1.13.4
>=sys-devel/gettext-0.18.2
@@ -65,6 +64,10 @@ BDEPEND="
PDEPEND="sys-apps/xdg-desktop-portal"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.14.4-fuse-3-slotted.patch
+)
+
python_check_deps() {
has_version -b "dev-python/pyparsing[${PYTHON_USEDEP}]"
}