summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-20 11:16:13 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-20 11:16:13 +0100
commit762b3c6697feae7c846a9636e7af82be9e59aafa (patch)
treef0d475ca802f02d71f7afa3dd1bcdd965e297465 /sci-physics
parentsci-physics/vmc: Remove old (diff)
downloadgentoo-762b3c6697feae7c846a9636e7af82be9e59aafa.tar.gz
gentoo-762b3c6697feae7c846a9636e7af82be9e59aafa.tar.bz2
gentoo-762b3c6697feae7c846a9636e7af82be9e59aafa.zip
sci-physics/bullet: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/bullet/Manifest3
-rw-r--r--sci-physics/bullet/bullet-2.86.ebuild69
-rw-r--r--sci-physics/bullet/bullet-2.89.ebuild90
-rw-r--r--sci-physics/bullet/bullet-3.05.ebuild86
-rw-r--r--sci-physics/bullet/files/bullet-2.89-no-dangling-pointer.patch26
-rw-r--r--sci-physics/bullet/metadata.xml2
6 files changed, 0 insertions, 276 deletions
diff --git a/sci-physics/bullet/Manifest b/sci-physics/bullet/Manifest
index 89ee08092cfb..a5d77918fa0f 100644
--- a/sci-physics/bullet/Manifest
+++ b/sci-physics/bullet/Manifest
@@ -1,4 +1 @@
-DIST bullet-2.86.tar.gz 25806558 BLAKE2B a8576d8dacd67b9789d32d7b1acc6c4025df3c15427c60d66f98b1906eee8b2b94e5b0108b9a8c00ca6261510ccaf57ba5c02c72fee8f528d4f723b304166731 SHA512 af8a6b282ab606437d7975a59cd8a9c2bf273c83b0e79f0c4c1de6fa51695ba6d5f3c853dce2fdba9cb55e7572214e15089e54db51afc465ca26f502cbd5a4f9
-DIST bullet-2.89.tar.gz 135742506 BLAKE2B 3725533bb50f3cf4783e21c57a5e3596f280d9aa3caa5b7a44925d4785206cc86514ff89c2cc1e33f8a14af7c8a5165190bb0515a6931fc4c7ec2e2b9aef3dd8 SHA512 3c4ba6a3b3623ef44dd4a23e0bc2e90dec1f2b7af463edcb886e110feac1dfb4a91945f0ed640052cac228318539e275976d37238102fb10a0f78aef065a730b
-DIST bullet-3.05.tar.gz 142858358 BLAKE2B d7ef2e68c0740e5bd2a728c576bcd3f07fff3680d8f604d7fd89bb6d7eb8c38f6205aea3bae300d70c2ec4e362c14e0567e3af3aabc893f8e33d979ffe8b3521 SHA512 4cb67547b466e01f6c2258b1f350fdfac0f2dc73a7962b6e196491e6722e1cd22cdfe80d7b2f4e1e92a90f91e277bff5cabfd0f55ef55010f9a4d7286843cecd
DIST bullet-3.07.tar.gz 148413637 BLAKE2B 776cd7651d11d865095ea000d353860bea09c6ff4ec8dd8e43282a78373e2830f6ce1ce2b87ed25a67be7bded297b3a6320b2872a71dfd3849e7b197c6d2c936 SHA512 31fc7cb4ed8b939abc9eeb0a8f6fff3a454ea4ebcffd797fd35a2320fe3ab222fcd315569809ea148d0efff47267f5eec9f4bf7aaf07730a06aa9babd2abc9a6
diff --git a/sci-physics/bullet/bullet-2.86.ebuild b/sci-physics/bullet/bullet-2.86.ebuild
deleted file mode 100644
index f983c772bb62..000000000000
--- a/sci-physics/bullet/bullet-2.86.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Continuous Collision Detection and Physics Library"
-HOMEPAGE="http://www.bulletphysics.com/"
-SRC_URI="https://github.com/bulletphysics/bullet3/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="+bullet3 doc double-precision examples extras test"
-
-RDEPEND="
- virtual/opengl
- media-libs/freeglut"
-DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen[dot] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.85-soversion.patch )
-
-DOCS=( AUTHORS.txt LICENSE.txt README.md )
-
-# Building / linking of third Party library BussIK does not work out of the box
-RESTRICT="test"
-
-S="${WORKDIR}/${PN}3-${PV}"
-
-src_prepare() {
- cmake_src_prepare
-
- # allow to generate docs
- sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CPU_DEMOS=OFF
- -DBUILD_OPENGL3_DEMOS=OFF
- -DBUILD_BULLET2_DEMOS=OFF
- -DUSE_GRAPHICAL_BENCHMARK=OFF
- -DINSTALL_LIBS=ON
- -DINSTALL_EXTRA_LIBS=ON
- -DBUILD_BULLET3=$(usex bullet3)
- -DBUILD_EXTRAS=$(usex extras)
- -DUSE_DOUBLE_PRECISION=$(usex double-precision)
- -DBUILD_UNIT_TESTS=$(usex test)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use doc; then
- doxygen || die
- HTML_DOCS+=( html/. )
- DOCS+=( docs/*.pdf )
- fi
-
- if use examples; then
- # throws QA warnings
- rm examples/ThirdPartyLibs/openvr/*/linux64/libopenvr_api.so || die
- DOCS+=( examples )
- fi
-}
diff --git a/sci-physics/bullet/bullet-2.89.ebuild b/sci-physics/bullet/bullet-2.89.ebuild
deleted file mode 100644
index 93b7355b91d8..000000000000
--- a/sci-physics/bullet/bullet-2.89.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="Continuous Collision Detection and Physics Library"
-HOMEPAGE="http://www.bulletphysics.com/"
-SRC_URI="https://github.com/bulletphysics/bullet3/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+bullet3 doc double-precision examples extras openmp tbb test threads"
-
-REQUIRED_USE="
- openmp? ( threads )
- tbb? ( threads )
-"
-
-RDEPEND="
- virtual/opengl
- media-libs/freeglut
- tbb? ( dev-cpp/tbb )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen[dot] )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.85-soversion.patch
- "${FILESDIR}"/${PN}-2.89-no-dangling-pointer.patch
-)
-
-DOCS=( AUTHORS.txt LICENSE.txt README.md )
-
-# Building / linking of third Party library BussIK does not work out of the box
-RESTRICT="test"
-
-S="${WORKDIR}/${PN}3-${PV}"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # allow to generate docs
- sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CPU_DEMOS=OFF
- -DBUILD_OPENGL3_DEMOS=OFF
- -DBUILD_BULLET2_DEMOS=OFF
- -DUSE_GRAPHICAL_BENCHMARK=OFF
- -DINSTALL_LIBS=ON
- -DINSTALL_EXTRA_LIBS=ON
- -DBUILD_BULLET3=$(usex bullet3)
- -DBUILD_EXTRAS=$(usex extras)
- -DUSE_DOUBLE_PRECISION=$(usex double-precision)
- -DBUILD_UNIT_TESTS=$(usex test)
- -DBULLET2_MULTITHREADING=$(usex threads)
- -DBULLET2_USE_OPEN_MP_MULTITHREADING=$(usex openmp)
- -DBULLET2_USE_TBB_MULTITHREADING=$(usex tbb)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use doc; then
- doxygen || die
- HTML_DOCS+=( html/. )
- DOCS+=( docs/*.pdf )
- fi
-
- if use examples; then
- # throws QA warnings
- rm examples/ThirdPartyLibs/openvr/*/linux64/libopenvr_api.so || die
- DOCS+=( examples )
- fi
-}
diff --git a/sci-physics/bullet/bullet-3.05.ebuild b/sci-physics/bullet/bullet-3.05.ebuild
deleted file mode 100644
index 0ba0a2d387cd..000000000000
--- a/sci-physics/bullet/bullet-3.05.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="Continuous Collision Detection and Physics Library"
-HOMEPAGE="https://www.bulletphysics.com/"
-SRC_URI="https://github.com/bulletphysics/bullet3/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc double-precision examples openmp tbb test threads"
-
-REQUIRED_USE="
- openmp? ( threads )
- tbb? ( threads )
-"
-
-RDEPEND="
- virtual/opengl
- media-libs/freeglut
- tbb? ( dev-cpp/tbb )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen[dot] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.85-soversion.patch )
-
-DOCS=( AUTHORS.txt LICENSE.txt README.md )
-
-# Building / linking of third Party library BussIK does not work out of the box
-RESTRICT="test"
-
-S="${WORKDIR}/${PN}3-${PV}"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # allow to generate docs
- sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CPU_DEMOS=OFF
- -DBUILD_OPENGL3_DEMOS=OFF
- -DBUILD_BULLET2_DEMOS=OFF
- -DUSE_GRAPHICAL_BENCHMARK=OFF
- -DINSTALL_LIBS=ON
- -DBUILD_BULLET3=ON
- -DBUILD_EXTRAS=OFF
- -DUSE_DOUBLE_PRECISION=$(usex double-precision)
- -DBUILD_UNIT_TESTS=$(usex test)
- -DBULLET2_MULTITHREADING=$(usex threads)
- -DBULLET2_USE_OPEN_MP_MULTITHREADING=$(usex openmp)
- -DBULLET2_USE_TBB_MULTITHREADING=$(usex tbb)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use doc; then
- doxygen || die
- HTML_DOCS+=( html/. )
- DOCS+=( docs/*.pdf )
- fi
-
- if use examples; then
- # throws QA warnings
- rm examples/ThirdPartyLibs/openvr/*/linux*/libopenvr_api.so || die
- DOCS+=( examples )
- fi
-}
diff --git a/sci-physics/bullet/files/bullet-2.89-no-dangling-pointer.patch b/sci-physics/bullet/files/bullet-2.89-no-dangling-pointer.patch
deleted file mode 100644
index 8eee0016ae28..000000000000
--- a/sci-physics/bullet/files/bullet-2.89-no-dangling-pointer.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 1c64add35ed4918222ceb4fe93b7bef0e2b4e41c Mon Sep 17 00:00:00 2001
-From: stolk <b.stolk@gmail.com>
-Date: Wed, 1 Apr 2020 10:59:16 -0700
-Subject: [PATCH] Do not return a dangling pointer!
-
-Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com>
----
- Extras/ConvexDecomposition/cd_wavefront.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Extras/ConvexDecomposition/cd_wavefront.cpp b/Extras/ConvexDecomposition/cd_wavefront.cpp
-index b33080964..53b5784df 100644
---- a/Extras/ConvexDecomposition/cd_wavefront.cpp
-+++ b/Extras/ConvexDecomposition/cd_wavefront.cpp
-@@ -437,7 +437,7 @@ const char **InPlaceParser::GetArglist(char *line, int &count) // convert sourc
- {
- const char **ret = 0;
-
-- const char *argv[MAXARGS];
-+ static const char *argv[MAXARGS];
- int argc = 0;
-
- char *foo = line;
---
-2.28.0
-
diff --git a/sci-physics/bullet/metadata.xml b/sci-physics/bullet/metadata.xml
index 3eb822b267c4..f7e1c944a877 100644
--- a/sci-physics/bullet/metadata.xml
+++ b/sci-physics/bullet/metadata.xml
@@ -19,9 +19,7 @@
for games and animation.
</longdescription>
<use>
- <flag restrict="&lt;=sci-physics/bullet-2.89" name="bullet3">Build Bullet 3</flag>
<flag restrict="&lt;=sci-physics/bullet-2.89" name="double-precision">Build libraries in double precision</flag>
- <flag restrict="&lt;=sci-physics/bullet-2.89" name="extras">Build additional libraries</flag>
<flag restrict="=sci-physics/bullet-2.89" name="tbb">Enable multithreading with the Intel Threads Building Block dev-cpp/tbb</flag>
</use>
<upstream>