summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2023-03-25 21:13:07 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-04-03 17:24:09 +0200
commitac1abcac0ffe2618b39f0e4b981442aae22edb2d (patch)
tree0ce1c1a7e6fa101efc2c5f2989533f04f20e076f /sci-physics/geant4_vmc
parentnet-im/mattermost-desktop-bin: add 5.3.1_rc1 (diff)
downloadgentoo-ac1abcac0ffe2618b39f0e4b981442aae22edb2d.tar.gz
gentoo-ac1abcac0ffe2618b39f0e4b981442aae22edb2d.tar.bz2
gentoo-ac1abcac0ffe2618b39f0e4b981442aae22edb2d.zip
sci-physics/geant4_vmc: add 6.1_p4, 6.3
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/geant4_vmc')
-rw-r--r--sci-physics/geant4_vmc/Manifest2
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-6.1_p4.ebuild80
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-6.3.ebuild79
3 files changed, 161 insertions, 0 deletions
diff --git a/sci-physics/geant4_vmc/Manifest b/sci-physics/geant4_vmc/Manifest
index 2247d3b867c6..c36bb4647817 100644
--- a/sci-physics/geant4_vmc/Manifest
+++ b/sci-physics/geant4_vmc/Manifest
@@ -1,3 +1,5 @@
DIST geant4_vmc-6.1_p2.tar.gz 5606450 BLAKE2B 943398e4cf9a8f4d6e44687f89eff6e6f09e4904b8a57684e202719162d861d5b370c1fc9bcf40de43aa607cfa89db1d1a740046a1ad9744ba2c538dbc8103f8 SHA512 97f825a32958d7da8d4086e87397c358b0331ac8f6630b83c1a8142f02be21093bed65c0841a24c0db5548adb611f52f2c5e05e92f39a67f13c70d76f901d47e
DIST geant4_vmc-6.1_p3.tar.gz 5605174 BLAKE2B 80d7936534d4102b545a4285b8ddba4eb7c9ec31b1343194da922a6c79730c1f779cc9719b1d2e5b4bcf02a681c371157057d727c5fa86633e6c7497d64206e0 SHA512 ccb568c2ce004300c7c6ad908aa8d97319f3c0d4add0da3ace418231906cf91ef9f73b5c774fbadd6e4473dcc1b49071023d7fa159b5864f03b28dae407074c6
+DIST geant4_vmc-6.1_p4.tar.gz 5606731 BLAKE2B 441a3398b472db13c5cb5219004c4d32c8ff07041e0c6335d40e6db8df23bc35d67ca2e6920a1b575f0fcb224b2d47ffa573dc5f9d23dac771ddf579b5bd9a2a SHA512 8751899e2db863017b6c14fc87fc172492dbcf26c089c4cea4b262b75e22ae7767d47e3019a3676315c0eb6052e99b6acd10a39135cd51e3ce0f9ea816c09ce6
DIST geant4_vmc-6.2.tar.gz 5743487 BLAKE2B 062fece07714f255eddd13c6bda660ea6737772fe7a43413df07c9ed221c0f80a872fe72614e5e4ad18396c72aae2c2000cdf6e3b1c2436f9419933ac32704bb SHA512 72651ab5261a398feb6f37271a41a5770334a20dc61be2046b19ca8ff4780cf7649136314e4a8597023d14782996d7ee0d047579b33a983c4dea9c21b32b4551
+DIST geant4_vmc-6.3.tar.gz 5737268 BLAKE2B 0de8b6eabd7aceebb8047daa2642bb5d41945abbbe751709fa7a8f4063dd1049676f5243eae17c2d572d232a28bf2f268d64fae72183d886a64af8a761679203 SHA512 4ca9d4593a10a25947eadc27de4460e2522077c499c73a59824f363b75922ae1d2695365fc941c60a7aa83f9b0ec030ac435926a729e764b88c768668b3c5671
diff --git a/sci-physics/geant4_vmc/geant4_vmc-6.1_p4.ebuild b/sci-physics/geant4_vmc/geant4_vmc-6.1_p4.ebuild
new file mode 100644
index 000000000000..d345df0c65eb
--- /dev/null
+++ b/sci-physics/geant4_vmc/geant4_vmc-6.1_p4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake virtualx
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+ MY_PV=$(ver_rs 1-2 -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="https://github.com/vmc-project/geant4_vmc"
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="doc examples geant3 +g4root vgm test"
+
+RDEPEND="
+ >=sci-physics/geant-4.11[c++17,opengl,geant3?]
+ sci-physics/root:=[c++17,-vmc(-)]
+ >=sci-physics/vmc-2.0:=[c++17]
+ vgm? ( <=sci-physics/vgm-5.0:= )"
+DEPEND="${RDEPEND}
+ test? ( >=sci-physics/geant-4.11[gdml] )"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+RESTRICT="
+ !examples? ( test )
+ !geant3? ( test )
+ !g4root? ( test )
+ !test? ( test )
+ !vgm? ( test )"
+
+DOCS=(history README.md)
+
+src_configure() {
+ local mycmakeargs=(
+ -DGeant4VMC_USE_VGM="$(usex vgm)"
+ -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
+ -DGeant4VMC_USE_G4Root="$(usex g4root)"
+ -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
+ -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
+ -DGeant4VMC_BUILD_G4Root_TEST="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc ; then
+ local dirs=(
+ source
+ $(usev g4root)
+ $(usev examples)
+ )
+ local d
+ for d in "${dirs[@]}"; do
+ doxygen "${d}"/Doxyfile || die
+ done
+ fi
+}
+
+src_test() {
+ export QT_DEBUG_PLUGINS=1
+ cd examples || die
+ virtx ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
+ virtx ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=(doc/.)
+ einstalldocs
+}
diff --git a/sci-physics/geant4_vmc/geant4_vmc-6.3.ebuild b/sci-physics/geant4_vmc/geant4_vmc-6.3.ebuild
new file mode 100644
index 000000000000..b379508aa225
--- /dev/null
+++ b/sci-physics/geant4_vmc/geant4_vmc-6.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake virtualx
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+ MY_PV=$(ver_rs 1-2 -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="https://github.com/vmc-project/geant4_vmc"
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="doc examples geant3 +g4root vgm test"
+
+RDEPEND="
+ >=sci-physics/geant-4.11.1:=[c++17,opengl,geant3?]
+ sci-physics/root:=[c++17,-vmc(-)]
+ >=sci-physics/vmc-2.0:=[c++17]
+ vgm? ( >=sci-physics/vgm-5.1:= )"
+DEPEND="${RDEPEND}
+ test? ( >=sci-physics/geant-4.11.1:=[gdml] )"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+RESTRICT="
+ !examples? ( test )
+ !geant3? ( test )
+ !g4root? ( test )
+ !test? ( test )
+ !vgm? ( test )"
+
+DOCS=(history README.md)
+
+src_configure() {
+ local mycmakeargs=(
+ -DGeant4VMC_USE_VGM="$(usex vgm)"
+ -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
+ -DGeant4VMC_USE_G4Root="$(usex g4root)"
+ -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
+ -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
+ -DGeant4VMC_BUILD_G4Root_TEST="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc ; then
+ local dirs=(
+ source
+ $(usev g4root)
+ $(usev examples)
+ )
+ local d
+ for d in "${dirs[@]}"; do
+ doxygen "${d}"/Doxyfile || die
+ done
+ fi
+}
+
+src_test() {
+ cd examples || die
+ virtx ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
+ virtx ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=(doc/.)
+ einstalldocs
+}