summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-04 21:48:21 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-04 22:57:02 +0100
commitc5869570c0a18934b6300b8e445aa1754756e8ed (patch)
treee059a7386e03438633f332530cda54eb6dc93db5 /sci-mathematics
parentsci-mathematics/cadical: drop old 1.8.0 (diff)
downloadgentoo-c5869570c0a18934b6300b8e445aa1754756e8ed.tar.gz
gentoo-c5869570c0a18934b6300b8e445aa1754756e8ed.tar.bz2
gentoo-c5869570c0a18934b6300b8e445aa1754756e8ed.zip
sci-mathematics/cadical: bump to 1.9.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cadical/Manifest1
-rw-r--r--sci-mathematics/cadical/cadical-1.9.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/cadical/Manifest b/sci-mathematics/cadical/Manifest
index ca2c1ce22bc6..8b39b30d4ef6 100644
--- a/sci-mathematics/cadical/Manifest
+++ b/sci-mathematics/cadical/Manifest
@@ -1 +1,2 @@
DIST cadical-1.9.4.tar.gz 691203 BLAKE2B 40fcb86e60b2c6e4f24d43976e12ae063aa00ccfc8cad78d27e85b863b0faee23213d210886fd2f374aa93b575b741fd079351d3655ee1ed5bb17f96cd0005b6 SHA512 a3477ac3a4ddcb8bb797653efa9afe992a84db94900394d401667a55630932a91e847fc943bf5509d6672523818233c247db0be4268b9d8aae1636bad1877bc3
+DIST cadical-1.9.5.tar.gz 691268 BLAKE2B 68c7fcc35ef0ad5082d5bbc828363ee45c2e637f281f1829ffb34047fff73775d34615e0ac37b8b49ff20b941db85b72c0dd6de0ab5ec5a690fd80fb5489b212 SHA512 b40727847ba0217f8d24e5468874264065c5ec9cbf0600d2e2395b8396a9d5f892127018ab9d1b930599a16a0817de5b0d29136c5dc74f2a72fb0f726e825271
diff --git a/sci-mathematics/cadical/cadical-1.9.5.ebuild b/sci-mathematics/cadical/cadical-1.9.5.ebuild
new file mode 100644
index 000000000000..4c087365b45b
--- /dev/null
+++ b/sci-mathematics/cadical/cadical-1.9.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplified Satisfiability Solver"
+HOMEPAGE="http://fmv.jku.at/cadical/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/arminbiere/${PN}.git"
+else
+ SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-rel-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-configure.patch"
+ "${FILESDIR}/${PN}-makefile.in-ar.patch"
+)
+
+DOCS=( CONTRIBUTING.md NEWS.md README.md )
+
+src_configure() {
+ tc-export AR
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe build/{cadical,mobical}
+
+ dolib.a build/libcadical.a
+ doheader src/cadical.hpp
+ doheader src/ccadical.h
+
+ einstalldocs
+}