summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2021-12-13 10:17:14 +1300
committerMichael Orlitzky <mjo@gentoo.org>2021-12-13 09:06:27 -0500
commit1b02c8596b03f6d20cd229f422b6d88d8dfb82cb (patch)
tree754cc85e7e731df7a3aa69d90199521a8015f1bc /sci-mathematics
parentsys-libs/csu-85-r1: fix compilation for newer setups (diff)
downloadgentoo-1b02c8596b03f6d20cd229f422b6d88d8dfb82cb.tar.gz
gentoo-1b02c8596b03f6d20cd229f422b6d88d8dfb82cb.tar.bz2
gentoo-1b02c8596b03f6d20cd229f422b6d88d8dfb82cb.zip
sci-mathematics/lrcalc: New upstream release
Closes: https://github.com/gentoo/gentoo/pull/23279 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/lrcalc/Manifest1
-rw-r--r--sci-mathematics/lrcalc/lrcalc-2.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/sci-mathematics/lrcalc/Manifest b/sci-mathematics/lrcalc/Manifest
index 35f1de381027..ac6b34ca58bc 100644
--- a/sci-mathematics/lrcalc/Manifest
+++ b/sci-mathematics/lrcalc/Manifest
@@ -1,2 +1,3 @@
DIST lrcalc-1.2.tar.gz 363120 BLAKE2B d3f652abfe38e81331dcbac7068d087b198445bf02dc5ccb5bcbd76b9bbc329687209e6ccf40ecd09f166e7d2da054edd0e5c2b18503d8e4d961ae4ad91b5152 SHA512 699f4c2ddabe5879542d5c11f3df3979a4e009ad37741711a70fb48b4a0d4a7969e5bb110adb63d4473f3c2b61d1efdb7228a6b74c5dd7e1b5aea8cf1d170fab
DIST lrcalc-2.0.tar.gz 420728 BLAKE2B 4d14276cf04cb1655d74bf9b85e12379034f43232db9b1a77db8ca4a508e5b490845fe44f4cfd533990bc567e51e817ca82aa917fce40517b8c8c9fc7dd2b4d3 SHA512 9224d1be971f53c0428f6f9a25850a892596175a6b5d6ca90b06abed00a72998b54fdfcd2be62318af142595f752b3a9ccc2efc1816ba7ce3ae59ecb43c49f81
+DIST lrcalc-2.1.tar.gz 425484 BLAKE2B 3c9d33942f44f8f6cf29e1da36ad5072b49ea3dd949f8c3e96a2fd55deec566828736ccc1da0ef32e528b8f4967bedbd46ca84f144e022a6916451c02befccc3 SHA512 76db29af51fb97e582d37b92a426cacf85fd61b8e7c2a70dc99dec23b396d62d996f0c66b5bbbd8b6928b46fa1186c9bb3c28aa91646cdccd38bd9b783af44d7
diff --git a/sci-mathematics/lrcalc/lrcalc-2.1.ebuild b/sci-mathematics/lrcalc/lrcalc-2.1.ebuild
new file mode 100644
index 000000000000..194251793e74
--- /dev/null
+++ b/sci-mathematics/lrcalc/lrcalc-2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Littlewood-Richardson Calculator"
+HOMEPAGE="https://sites.math.rutgers.edu/~asbuch/lrcalc/"
+SRC_URI="https://sites.math.rutgers.edu/~asbuch/lrcalc/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}