summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-24 14:48:16 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-24 14:48:16 +0100
commit4df9e749ae042a6b21c69195d1b44cad46a3029f (patch)
tree2325568bde422b2819e175deefb66ac8a410fbb5 /sci-libs
parentsci-libs/nanoflann: Bump to 1.3.2 (diff)
downloadgentoo-4df9e749ae042a6b21c69195d1b44cad46a3029f.tar.gz
gentoo-4df9e749ae042a6b21c69195d1b44cad46a3029f.tar.bz2
gentoo-4df9e749ae042a6b21c69195d1b44cad46a3029f.zip
sci-libs/nanoflann: Sync live ebuild
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nanoflann/nanoflann-9999.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/sci-libs/nanoflann/nanoflann-9999.ebuild b/sci-libs/nanoflann/nanoflann-9999.ebuild
index 4db99558405a..0e91a4124d0e 100644
--- a/sci-libs/nanoflann/nanoflann-9999.ebuild
+++ b/sci-libs/nanoflann/nanoflann-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C++ header-only library for Nearest Neighbor (NN) search wih KD-trees"
HOMEPAGE="https://github.com/jlblancoc/nanoflann"
@@ -18,18 +18,16 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE=""
+IUSE="examples test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-cpp/eigen:3"
DEPEND="${RDEPEND}"
-src_prepare() {
- cmake-utils_src_prepare
-
- # do not compile examples
- cmake_comment_add_subdirectory examples
-}
-
-src_test() {
- "${CMAKE_MAKEFILE_GENERATOR}" -C "${BUILD_DIR}" -j1 test
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
}