summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bettler <thomas.bettler@gmail.com>2023-11-25 09:17:47 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-29 15:13:25 +0100
commit316c0d4e152db3677fc762debdc88f1056bf7831 (patch)
treeeea15a7d6e0dd7a3bdf0c5dd2503abd949130fd7 /sci-libs
parentapp-misc/astrolog: Stabilize 7.60 ppc, #914519 (diff)
downloadgentoo-316c0d4e152db3677fc762debdc88f1056bf7831.tar.gz
gentoo-316c0d4e152db3677fc762debdc88f1056bf7831.tar.bz2
gentoo-316c0d4e152db3677fc762debdc88f1056bf7831.zip
sci-libs/pdal: bump version to 2.6.0
Signed-off-by: Thomas Bettler <thomas.bettler@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33975 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pdal/Manifest1
-rw-r--r--sci-libs/pdal/pdal-2.6.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sci-libs/pdal/Manifest b/sci-libs/pdal/Manifest
index 5df6933eface..143776655a40 100644
--- a/sci-libs/pdal/Manifest
+++ b/sci-libs/pdal/Manifest
@@ -1,2 +1,3 @@
DIST PDAL-2.4.3-src.tar.gz 100758279 BLAKE2B 7c157bb51416b24bd8896a62e71a186bc9a45b34d5ab58fadbe691cb1abc9595f598fcf92ec528c9103f646c21f940b26fbf199a998e707d17f1527eb2957a85 SHA512 ed342c29d10c0506e1c0f5ee4dba531189000dd0cc6912f681a95b7c56483d6136e515771a174e20906b1cd81dfd101d53be0cbaf200480d81d053d7dec8a386
DIST PDAL-2.5.3-src.tar.bz2 102669314 BLAKE2B 1c6c8406f8de65a04364cc1141be809c00ea716fcfd5578833883357258855b3f7e70ea03c86f487dff0bc98072c29bed45a613c14ace05aef6ae49627b40374 SHA512 f67a303711b7d9e9dc14260afb96d299bcd5327ba0cc947143a583f55bd532a248b131e4602fd37d711ad0084e8601420828dacac40c414b95b8e9f9e8175e1b
+DIST PDAL-2.6.0-src.tar.bz2 87271277 BLAKE2B 56899d1637e79845451132d177eda1b5ae3a7c81d2a61f97b5048eeadc43a2f087a06c52de0a828f8b7bf111467a03e32288b553dadd34f6aab6d51e2b653874 SHA512 61b2575fc5d2751f1e34925e948aca9936b8de72c0b596f9809cdf9156a15e94f670db22bd68c45e484783ba112a6bc43c7309a62e3aa3158567437195901cbd
diff --git a/sci-libs/pdal/pdal-2.6.0.ebuild b/sci-libs/pdal/pdal-2.6.0.ebuild
new file mode 100644
index 000000000000..906fdca0a265
--- /dev/null
+++ b/sci-libs/pdal/pdal-2.6.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A C++ library for translating and manipulating point cloud data"
+HOMEPAGE="https://pdal.io/"
+SRC_URI="https://github.com/PDAL/PDAL/releases/download/${PV}/PDAL-${PV}-src.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/16"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="postgres test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="
+ net-misc/curl
+ app-arch/zstd:=
+ dev-libs/libxml2
+ dev-libs/openssl:=
+ sci-libs/gdal:=
+ sci-libs/libgeotiff:=
+ sys-libs/zlib
+ postgres? ( dev-db/postgresql:*[xml] )
+"
+# temporarily drop libunwind from RDEPEND and build w/o backtrace WRT https://github.com/PDAL/PDAL/issues/4211
+#sys-libs/libunwind:=
+
+DEPEND="
+ test? ( sci-libs/gdal[geos,jpeg,png] )
+ ${RDEPEND}
+"
+
+S="${WORKDIR}/PDAL-${PV}-src"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PLUGIN_PGPOINTCLOUD="$(usex postgres)"
+ -DWITH_COMPLETION=ON
+ -DWITH_BACKTRACE=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ --exclude-regex '(pgpointcloudtest|pdal_io_bpf_base_test|pdal_io_bpf_zlib_test|pdal_filters_overlay_test|pdal_filters_stats_test|pdal_app_plugin_test|pdal_merge_test|pdal_io_stac_reader_test)'
+ --output-on-failure
+ -j1
+ )
+
+ cmake_src_test
+}