summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-05-14 19:07:11 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-05-14 19:07:52 +0200
commitc20b2f88a074632d3741ae5b3f498483e84fe388 (patch)
treeb449d2c4d3c3202992d972f357f4d1ed47b43482 /sci-libs/tensorpipe
parentsci-libs/datasets: enable jiwer depend tests (diff)
downloadgentoo-c20b2f88a074632d3741ae5b3f498483e84fe388.tar.gz
gentoo-c20b2f88a074632d3741ae5b3f498483e84fe388.tar.bz2
gentoo-c20b2f88a074632d3741ae5b3f498483e84fe388.zip
sci-libs/tensorpipe: enable cuda
Closes: https://bugs.gentoo.org/906204 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/tensorpipe')
-rw-r--r--sci-libs/tensorpipe/metadata.xml3
-rw-r--r--sci-libs/tensorpipe/tensorpipe-2022.05.13-r1.ebuild (renamed from sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild)14
2 files changed, 15 insertions, 2 deletions
diff --git a/sci-libs/tensorpipe/metadata.xml b/sci-libs/tensorpipe/metadata.xml
index a676d5dbb87a..0771cea93d5e 100644
--- a/sci-libs/tensorpipe/metadata.xml
+++ b/sci-libs/tensorpipe/metadata.xml
@@ -5,6 +5,9 @@
<email>tupone@gentoo.org</email>
<name>Tupone Alfredo</name>
</maintainer>
+ <use>
+ <flag name="cuda">Add support for CUDA processing</flag>
+ </use>
<upstream>
<remote-id type="github">pytorch/tensorpipe</remote-id>
</upstream>
diff --git a/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild b/sci-libs/tensorpipe/tensorpipe-2022.05.13-r1.ebuild
index 23422f9cc125..734a2050cf07 100644
--- a/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild
+++ b/sci-libs/tensorpipe/tensorpipe-2022.05.13-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,16 +15,26 @@ SRC_URI="https://github.com/pytorch/${PN}/archive/${CommitId}.tar.gz
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
+IUSE="cuda"
RESTRICT=test
RDEPEND="
dev-libs/libuv
+ cuda? (
+ dev-util/nvidia-cuda-toolkit:=
+ )
"
DEPEND="${RDEPEND}
dev-libs/libnop
"
-BDEPEND=""
S="${WORKDIR}"/${PN}-${CommitId}
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DTP_USE_CUDA=$(usex cuda)
+ )
+ cmake_src_configure
+}