summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-25 01:51:07 +0100
committerSam James <sam@gentoo.org>2022-08-25 01:52:15 +0100
commit5611848da693494fe7a710836779c9c25b85c0fa (patch)
tree3745e4fd2ef873ae8ee4e7eaff5df4f5737a8433 /sci-libs/superlu
parentmedia-plugins/kodi-pvr-vdr-vnsi: add 19.0.5 (diff)
downloadgentoo-5611848da693494fe7a710836779c9c25b85c0fa.tar.gz
gentoo-5611848da693494fe7a710836779c9c25b85c0fa.tar.bz2
gentoo-5611848da693494fe7a710836779c9c25b85c0fa.zip
sci-libs/superlu: fix Manifest (fix 4.3 ebuild distfile)
The 4.3 tarball (which got replaced upstream) was actually, seemingly, partly version 4.1 instead? Mirror the "bad" (nothing malicious, just mislabelled version) copy to my devspace at dev.gentoo.org and keep using it in 4.3-r2, and add a fixed 4.3-r3 using the fixed 4.3 upstream version. Closes: https://bugs.gentoo.org/862597 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/superlu')
-rw-r--r--sci-libs/superlu/Manifest1
-rw-r--r--sci-libs/superlu/superlu-4.3-r2.ebuild8
-rw-r--r--sci-libs/superlu/superlu-4.3-r3.ebuild86
3 files changed, 93 insertions, 2 deletions
diff --git a/sci-libs/superlu/Manifest b/sci-libs/superlu/Manifest
index 21a70aa35411..b70359d59397 100644
--- a/sci-libs/superlu/Manifest
+++ b/sci-libs/superlu/Manifest
@@ -1,2 +1,3 @@
DIST superlu-5.3.0.tar.gz 2483070 BLAKE2B 2e877c12b698fae6649d3146d4a22a8c701df813d1fa037b7707081229de09e102660e75dd32138264ad9e01e5b3e820012106cd2b0d46cc2a1c37dc5eaafec2 SHA512 1461b52bc18a8b0345beb70fdd46e07df497a13be840bcc061158ea1d0e61c8745806d1ad21cb2723db80f5ed762c3741f9c0ded2b2013df46da0e8bb6b77b83
+DIST superlu_4.3.new.tar.gz 2875951 BLAKE2B 4208edb7df0babc0bb7e21077c6e0a00a10766a2d01b2da47f05ecdb232ca3309a2bce00f2cd1b709a8c01b7de2276e4f7d63856ace2e93c3598f1cdcdc12712 SHA512 57799051c5cd394e4cb1b89481a4706ee0a21159f06941bab4a39dfe30f4b6ccdf67042c6ec2c479a12deee0ed26c3707069a5b53281fb26b6c752ca77102aad
DIST superlu_4.3.tar.gz 2876631 BLAKE2B 0a563e6730394f8e69fe13f1418f9f046bd37c848c51063e93a24a209e50a67f91b725eb3978fd6c4d28e51615806d6c0b6a2539cbc0d7fd11b5e4f0a9360148 SHA512 5c13da47b79160be14719f62ccdf5d59142a172e25a988fa340eaeb001a64d7f45ba39e675cb7aa3571bec52cb3a7cda0bb7a708c9608184ba6251edb7990e8c
diff --git a/sci-libs/superlu/superlu-4.3-r2.ebuild b/sci-libs/superlu/superlu-4.3-r2.ebuild
index f4d198c2f6de..ed26d8d30dc2 100644
--- a/sci-libs/superlu/superlu-4.3-r2.ebuild
+++ b/sci-libs/superlu/superlu-4.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,11 @@ MY_PN=SuperLU
DESCRIPTION="Sparse LU factorization library"
HOMEPAGE="https://crd-legacy.lbl.gov/~xiaoye/SuperLU/"
-SRC_URI="https://crd-legacy.lbl.gov/~xiaoye/SuperLU/${PN}_${PV}.tar.gz"
+#SRC_URI="https://portal.nersc.gov/project/sparse/${PN}/${PN}_${PV}.tar.gz"
+# Archive of weird franken-version which we used as 4.3 but upstream changed
+# the above tarball ^. The franken-version we used seemed to have 4.1 references in it?
+# bug #862597.
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}_${PV}.tar.gz"
S="${WORKDIR}/${MY_PN}_${PV}"
LICENSE="BSD"
diff --git a/sci-libs/superlu/superlu-4.3-r3.ebuild b/sci-libs/superlu/superlu-4.3-r3.ebuild
new file mode 100644
index 000000000000..028c3d805d0c
--- /dev/null
+++ b/sci-libs/superlu/superlu-4.3-r3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fortran-2 multilib toolchain-funcs
+
+MY_PN=SuperLU
+
+DESCRIPTION="Sparse LU factorization library"
+HOMEPAGE="https://crd-legacy.lbl.gov/~xiaoye/SuperLU/"
+# See bug #862597 for .new, can drop on next version
+SRC_URI="https://portal.nersc.gov/project/sparse/${PN}/${PN}_${PV}.tar.gz -> ${PN}_${PV}.new.tar.gz"
+S="${WORKDIR}/${MY_PN}_${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/blas"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( app-shells/tcsh )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-format-security.patch
+)
+
+src_prepare() {
+ unset VERBOSE
+ sed \
+ -e "s:= ar:= $(tc-getAR):g" \
+ -e "s:= ranlib:= $(tc-getRANLIB):g" \
+ -i make.inc || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ )
+
+ tc-export PKG_CONFIG
+
+ econf "${myeconfargs[@]}"
+
+ rm EXAMPLE/*itersol1 || die
+}
+
+src_test() {
+ cd TESTING || die
+ emake -j1 \
+ CC="$(tc-getCC)" \
+ FORTRAN="$(tc-getFC)" \
+ LOADER="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ FFLAGS="${FFLAGS}" \
+ LOADOPTS="${LDFLAGS}" \
+ BLASLIB="$($(tc-getPKG_CONFIG) --libs blas)" \
+ SUPERLULIB="${S}/SRC/.libs/libsuperlu$(get_libname)" \
+ LD_LIBRARY_PATH="${S}/SRC/.libs" \
+ DYLD_LIBRARY_PATH="${S}/SRC/.libs"
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dodoc DOC/ug.pdf
+ dodoc -r DOC/html/.
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc -r EXAMPLE FORTRAN
+ fi
+
+ find "${ED}" -name "*.a" -delete || die
+}